[304.88] No tty when starting X

When i boot into system, everything is fine, tty’s are working.
After i start X (manually, i prefer to log into tty, then manually start X, if i need it) and then switch to tty, display gets no signal at all.
I found threads about that issue and the driver version 304.88 should fix this problem but it doesn’t work on my system. Framebuffer/KMS is also disabled by GRUB (nomodeset and vga=normal both tried and didn’t take any affect).

Arch Linux 3.10.3
Nvidia 304.88-12 Geforce 9400M

If additional info needed, please tell me what you need. Thanks in advance

Where’s nvidia-bug-report?

nvidia-bug-report.log (181 KB)

You’re a Mac user, thus you seem to get EFIFB automatically and this configuration is not supported.

[    0.563323] efifb: probing for efifb
[    0.565942] efifb: framebuffer at 0xc0010000, mapped to 0xffffc90004c80000, using 6400k, total 6400k
[    0.565944] efifb: mode is 1280x800x32, linelength=8192, pages=1
[    0.565946] efifb: scrolling: redraw
[    0.565948] efifb: Truecolor: size=8:8:8:8, shift=24:16:8:0
[    0.568791] Console: switching to colour frame buffer device 160x50
[    0.571531] fb0: EFI VGA frame buffer device

Hopefully NVIDIA will find a way to play nicely with different framebuffers in the future - right now only VesaFB works for some people (including me).

Yes I’m a Mac User Macbook Pro 5,5

I tried it with nomodeset and vga=normal to disable the Framebuffer/KMS and this doesen’t take any affect.

I tried it with nouveau driver and it worked (getting back to tty), but the external monitor (DVI) was flickering and so i changed over to nvidia driver and get those problems.

So should i install VesaFB instead of nvidia? Or do i need the nvidia driver, too?

At least here on this PC the Linux kernel cannot switch from UEFIFB set by BIOS to any other frame buffer, so I really have no idea how you can solve your problem other than hoping that NVIDIA will someday fix this issue.

NVIDIA internal Bug ID: 1343533 to track this issue.


I wanted to ask if there has been any update on this issue so far on my system (Macbook Pro 5.5 Linux Sabayon Kernel 3.13) with NVIDIA 331.38 this bug still occurs.