Ubuntu 15.04 External Monitor connection causes black screen on laptop with GTX 870m.

Im running Ubuntu 15.04 GNOME with gnome 3.16.

I have the following driver installed 352.30 and a NVIDIA 870m GTX.

Whenever I connect an external monitor to my laptop both displays go black and seem to flicker. If I remove the external monitor than the laptop screen comes back.

I looked at Xorg.0.log and noticed the following error when connecting the monitor.

[ 859.930] have a master to look out for
[ 859.964] need to create shared pixmap 1(II) intel(G0): switch to mode 1920x1080@60.0 on DP1 using pipe 0, position (1920, 0), rotation normal, reflection none
(EE) [mi] EQ overflowing. Additional events will be discarded until existing events are processed.
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x56) [0x7f48cf19a556]
(EE) 1: /usr/bin/X (mieqEnqueue+0x24b) [0x7f48cf17c69b]
(EE) 2: /usr/bin/X (QueuePointerEvents+0x52) [0x7f48cf056ae2]
(EE) 3: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f48c3cec000+0x5b3c) [0x7f48c3cf1b3c]
(EE) 4: /usr/lib/xorg/modules/input/synaptics_drv.so (0x7f48c3cec000+0x75a2) [0x7f48c3cf35a2]
(EE) 5: /usr/bin/X (0x7f48cefe7000+0x96708) [0x7f48cf07d708]
(EE) 6: /usr/bin/X (0x7f48cefe7000+0xbfa79) [0x7f48cf0a6a79]
(EE) 7: /lib/x86_64-linux-gnu/libc.so.6 (0x7f48cccac000+0x352f0) [0x7f48ccce12f0]
(EE) 8: /lib/x86_64-linux-gnu/libc.so.6 (sigprocmask+0x10) [0x7f48ccce1560]
(EE) 9: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f48c7059000+0x72a96) [0x7f48c70cba96]
(EE) 10: /usr/lib/xorg/modules/drivers/intel_drv.so (0x7f48c7059000+0x737b1) [0x7f48c70cc7b1]
(EE) 11: /usr/bin/X (xf86CrtcSetModeTransform+0x13b) [0x7f48cf0b5cfb]
(EE) 12: /usr/(EE) 15: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so (0x7f48c73f9000+0x5c33cd) [0x7f48c79bc3cd]bin/X (0x7f48cefe7000+0xd7e3e) [0x7f48cf0bee3e]
(EE) 13: /usr/bin/X (RRCrtcSet+0x29d) [0x7f48cf0ffead]
(EE) 14: /usr/bin/X (ProcRRSetCrtcConfig+0x394) [0x7f48cf101304]
(EE) 15: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/nvidia_drv.so (0x7f48c73f9000+0x5c33cd) [0x7f48c79bc3cd]
(EE) 16: /usr/bin/X (0x7f48cefe7000+0x580a7) [0x7f48cf03f0a7]
(EE) 17: /usr/bin/X (0x7f48cefe7000+0x5c29b) [0x7f48cf04329b]
(EE) 18: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf0) [0x7f48ccccca40]
(EE) 19: /usr/bin/X (0x7f48cefe7000+0x4662e) [0x7f48cf02d62e]
(EE) [mi] These backtraces from mieqEnqueue may point to a culprit higher up the stack.
(EE) [mi] mieq is NOT the cause. It is a victim.
[ 860.504] [mi] Increasing EQ size to 1024 to prevent dropped events.
[ 860.504] [mi] EQ processing has resumed after 50 dropped events.
[ 860.504] [mi] This may be caused my a misbehaving driver monopolizing the server’s resources.

Is their anything I can do to remedy this issue?

Seems like each nvidia driver fixes one issue but exposes another :(

Previously it was the boot screen was black until I closed the lid and reopened it to have it work again. Now it works just with no external monitors.

I have the exact same issue when I switch from the default X.org-driver to the NVIDIA driver (also on Ubuntu GNOME 15.04, but with a 660M). I will have to check my log if it looks the same, but the symptoms you describe sound exactly the same.
Have you already found a way to solve this?

Hi guys,

Recently had this issue, Once the screen goes Black, try giving the gnome shell a restart (alt + f2, r, enter). This worked for awhile, annoyingly this no longer solves it with the new drivers though (352.41). If anyone finds a work around for the new drivers in the 15.10 Beta 2 build of Ubuntu Gnome let me know!

Running an Optimus system so Intel 4000 + Nvidia GeForce 750M - for reference only.