Ubuntu 18.04 - Driver 440 installed but not running

Hi,

I am using a Gigabyte Aero 15w8 and recently I’ve had to do a full reinstall of Ubuntu 18.04.
I’ve installed nvidia-driver-440 along nvidia-prime through the ppa but for some reason my GC doesn’t start even when doing a prime-select nvidia (and rebooting of course), and the iGP is used instead

It seams the driver is correctly installed but isn’t running. I’ve tried many other versions of the driver but to no avail.

Here are some outputs:

$ sudo lshw -c video
*-display UNCLAIMED
description: VGA compatible controller
product: GP106M [GeForce GTX 1060 Mobile]
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller bus_master cap_list
configuration: latency=0
resources: memory:ac000000-acffffff memory:80000000-8fffffff memory:90000000-91ffffff ioport:4000(size=128) memory:ad000000-ad07ffff
*-display
description: VGA compatible controller
product: Intel Corporation
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pciexpress msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:143 memory:ab000000-abffffff memory:40000000-4fffffff ioport:5000(size=64) memory:c0000-dffff

$ glxinfo | grep “OpenGL renderer”
OpenGL renderer string: Mesa DRI Intel® UHD Graphics 630 (Coffeelake 3x8 GT2)

$ dkms statu
nvidia, 440.82, 4.15.0-101-generic, x86_64: installed

$ nvidia-smi
NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

I’m at my wits end, so I wouldn’t mind some help ^^
Thank you

nvidia-bug-report.log (1.3 MB)

Please disable secure boot in bios.

That fixed it, thanks ! :)