Ubuntu 18.04 ROG Laptop has Unknown Display 800x600 after updating software


My laptop which was working fine having installed NVIDIA drivers is now only operating at 800x600
resolution following a linux software update and reboot.

Output of ubuntu-drivers devices is:

== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00001C60sv00001043sd0000184Ebc03sc00i00
vendor   : NVIDIA Corporation
model    : GP106M [GeForce GTX 1060 Mobile 6GB]
driver   : nvidia-driver-430 - third-party free
driver   : nvidia-driver-415 - third-party free
driver   : nvidia-driver-435 - third-party free recommended
driver   : nvidia-driver-410 - third-party free
driver   : nvidia-driver-390 - third-party free
driver   : xserver-xorg-video-nouveau - distro free builtin

I.e. using a GTX 1060.

I have tried blacklisting the nouveu driver, and

sudo ubuntu-drivers autoinstall

I also tried

sudo apt-get remove nvidia-*
    sudo apt-get install nvidia-driver-435

and running the downloaded ‘.run’ all without success.

I was expecting to attach the bug report file but cannot see any attach/paperclip button. Any help appreciated. (edit) Found it. Things are not easy in 800x600.

nvidia-bug-report.log.gz (86.6 KB)

You have secure boot enabled so the nvidia driver doesn’t load since it isn’t signed. Please disable secure boot in bios.


For information I had not changed the BIOS previously when the display was working at full resolution. Perhaps it was using a default driver.

I have disabled secure boot in the BIOS and rebooted but the situation remains the same. Is there something else I should do? (I have gone back into the BIOS to confirm secure boot is actually disabled). Still showing unknown display.

Make sure no stray blacklist files remain:
sudo rm /lib/modprobe.d/blacklist-nvidia.conf /etc/modprobe.d/blacklist-nvidia.conf
sudo update-initramfs -u
then reboot and create a new nvidia-bug-report.log.

Thanks for your help! The screen is now back to full resolution.

For completeness I’ll attach the new bug report. (edit) paperclip icon leads to selecting the nvidia-bug-report.log file but with no upload following open. So can’t upload new file.