Ubuntu 19.04, X-Server isn't starting on GTX 970

Hi there.

After updating my system from Ubuntu 18.04 to 18.10 my X-Server wasn’t starting anymore. So I updated from 18.10 to 19.04 hopefully to have a running system after that.
I tried everything with no success. I tried to install from the repo’s, I tried the NVIDIA*.run installer and I tried it from the ppa.
Maybe I find some help here, I would appreciate it.

If you need some further information please let me know and you will get it.

nvidia-bug-report.log.gz (229 KB)

Please try this:

  • uninstall the .run installer using the --uninstall option
  • reboot, hold down shift to get to the grub menu and select the current 5.x kernel
  • install the driver from that (sudo apt install nvidia-driver-430)

If it still doesn’t work, please create a new nvidia-bug-report.log

Thanks for your reply.

- uninstall the .run installer using the --uninstall option

Done. There was nothing to do.

- reboot, hold down shift to get to the grub menu and select the current 5.x kernel

Done. But I had to boot into Recovery Mode because normal boot isn’t still working.

- add the ubuntu graphics ppa https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

It was already added.

- install the driver from that (sudo apt install nvidia-driver-430)

Was already installed.

Reboot still ended in a flashing cursor in the left upper corner and I wasn’t able to get in console-modus with ctrl+alt F2. It seems that the X-Server isn’t starting but crashing?

nvidia-bug-report.log.gz (93.4 KB)

This looks like you somehow managed to install the non-glvnd compat libs which are broken in the 430 driver. Please downgrade to the 418 driver using

sudo apt install nvidia-driver-418
sudo apt install nvidia-driver-418

Done. But nothing changed. It still runs into a flashing cursor and dies there…

nvidia-bug-report.log.gz (94.5 KB)

From what I see in the logs, the login (GDM) is coming up fine and after logon, the xserver doesn’t come up?
Please check if removing

quiet splash

from kernel command line helps.

The login will only shows up when I’m booting my 4.x Kernel, using the nouveau driver. When I’m booting with my 5.x kernel there is no login screen showing up. It stops right before it has to show up. This is what I mean with only a flashing cursor in the left upper corner appears and nothing more is happing. Then I have to hard reset my system.
Do you need some more information like demsg or something like this?

The logs tell that when booting into the 5.x kernel, the driver gets loaded and the Xserver starts correctly using the nvidia driver and then stops. Must be something different than the driver.
Please boot into the 5.x kernel, then reboot to recovery and run

sudo journalctl -b-1 --no-pager >journal.txt

and attach the output file.
Maybe just GDM is freaking out again, you could try if replacing it with lightdm helps:

sudo apt install lightdm

then select lightdm when asked which to use as default.

I’m a little bit confused because I’m using LightDM all of the time and you saw GDM in the logs.
Maybe there’s something wrong?

I attached the requested file and hopefully there’s a hint of what is getting wrong.
journal.txt (400 KB)

GDM was just a guess.
According to the logs, this is happening:
lightdm starts->xserver starts->unity-greeter crashes->xserver stops->lightdm restarts
but it is unclear to me why this is happening.
Please post the output of
ls -l /usr/lib/x86_64-linux-gnu

Also check if gdm works
sudo dpkg-reconfigure gdm
and remove your xorg.conf.

sudo dpkg-reconfigure gdm3
and remove your xorg.conf.

Done. This also doesn’t work. But I’m able to log into console now when I’m booting the 5.x Kernel.
A little step in the right direction.

ls -l /usr/lib/x86_64-linux-gnu

This output is in the file I attached.
x86_64-linux-gnu.txt (211 KB)

The client libs also seem to be correctly installed. Please attach a new journal output when running GDM, maybe this yields some more info.

Here we go…
journal.txt (270 KB)

gdm is failing with the same error:

kernel: traps: gnome-session-c[3369] trap divide error ip:7fa02c5abe3a sp:7ffca36e7760 error:0 in libGLX_nvidia.so.418.56

No real idea where that comes from, never seen it. Two things to try

  • check your system memory
  • downgrade to a v390 driver
- check your system memory

Checked. You were right. There was a problem with a RAM module. I bought a new one, but the error is still there.

downgrade to a v390 driver

This one I was trying, too. But no luck, same error.

So, what I have done now:
Bought a SSD and install a clean version of Ubuntu 18.04.2. Install nvidia-driver-418 and everything is fine again. I don’t now why 19.04 hates my hardware. Maybe I will tryout 19.10, but on a test partition. ;-)

I want to thank you for your time and keep it up! Nice work!