X server doesn't start on ubuntu 18.10 (kernel 4.18.0-12) with Quadro K4200

I have a new box I’ve recently built with a core i9 CPU, a Z390 motherboard, and a K4200. After figuring out how to get nomodeset to take effect, I was eventually able to get things working but only with 18.04. Neither a direct installation of 18.10, nor an upgrade of 18.04 to 18.10 (after installing 415.18 drivers) yielded success. I’m typing this from 18.04 running 415.18 and things seem to work fine, but not so with 18.10.

I can switch to a TTY (Ctrl Alt-F1) at boot up to get a shell prompt, but no graphics appear. What might I do to debug this from the TTY shell?

Thanks,

Cyrus

nvidia-bug-report.log.gz (1.02 MB)

The X server starts and then just stops. Looks more like GDM is misbehaving. Try installing/enabling lightdm.
sudo apt install lightdm
sudo systemctl enable ligtdm
You could also check if the gdm user is incorrectly created like here: https://devtalk.nvidia.com/default/topic/1044730/linux/x-displays-in-a-small-section-of-screen-something-in-my-grub-setup-wrong-/post/5301897/#5301897

Generix, thanks for the tip. It turns out that the problem was that I didn’t have the:

WaylandEnable=false

line uncommented in /etc/gdm3/custom.conf.

I’m curious if this means that I can get rid of the nomodeset in grub.cfg now, but haven’t tried it yet.

That’s rather odd as nomodeset should have the same effect as WaylandEnable=false. Looks like something more is broken with gdm.