Ubuntu 20.04 and RTX A2000 (Lenovo P1 Gen4) screen glitches/offset

Hi everyone,
I am having an issue on a Lenovo P1 Gen4 and its Nivida RTX A2000 gpu.
From time to time a part of the screen on the left appears on the right side (is it what we call a screen offset?).
I am running Ubuntu 20.04 with HWE (kernel 5.13.0-39) and Nvidia drivers 510.54 coming from Ubuntu graphics drivers PPA (https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa?field.series_filter=focal)
I tried with 470-103 drivers too but I am getting the same issue.
Thanks in advance for your help :)

nvidia-bug-report.log.gz (522.9 KB)

Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post.

@generix Sure. Please find it attached to my post.

Since this is a hybrid graphics notebook, I’d rather suspect a bug in the intel driver.

i915 0000:00:02.0: [drm] ERROR CPU pipe A FIFO underrun

is this happening spontaneously during runtime and vanishing again or sometimes right after boot and stays until reboot?

I used prime-select to set the graphic card to use to be the Nvidia one.
This screen offset is not something that stays more than a second, it just appears from time to time. Sometimes it does it once but sometimes multiple times in a row. I have no idea what is triggering it :(
I have seen this Intel errors but as I am only using the Nvidia card, I didn’t think it could be the root cause.
I have tried what I have found here i5-10210U flickering display (built-in, HDMI and miniDP) and FIFO underrun while using USB and deep package C-states (#2077) · Issues · drm / intel · GitLab without success.

I also saw this message in journal

Mar 28 10:42:02 e669966 kernel: [drm:nv_drm_master_set [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership
Mar 28 10:42:02 e669966 kernel: [drm:nv_drm_master_set [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership
Mar 28 10:42:02 e669966 kernel: [drm:nv_drm_master_set [nvidia_drm]] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership
Mar 28 10:42:06 e669966 kernel: i915 0000:00:02.0: [drm] *ERROR* CPU pipe A FIFO underrun
Mar 28 11:33:12 e669966 kernel: DMAR: DRHD: handling fault status reg 3
Mar 28 11:33:12 e669966 kernel: DMAR: [DMA Read] Request device [00:02.0] PASID ffffffff fault addr 17ea0b000 [fault reason 06] PTE Read access is not set

While the nvidia gpu is used for rendering, the internal display is still driven by the intel gpu.
You could try upgrading kernel+firmware using the liquorix ppa and the updated firmware package

@generix disabling Panel Self Refresh (PSR) is helping a lot. I haven’t seen this glitch/offset issue for a couple of hours now :)
I edited /etc/default/grub added to GRUB_CMDLINE_LINUX_DEFAULT the kernel option i915.enable_psr=0 to disable PSR updated grub with sudo update-grub and then restarted.