Ubuntu 20.04 fresh install looking for how to use PRIME to use iGPU on desktop intel + GTX 1060

I posted in askubuntu, but figure this may actually be an issue with me not knowing how to use PRIME

Essentially I’ve read a bit here on what PRIME is, and it seems to be taking the dGPU and rendering X with it… I would guess to help the iGPU? I do not want this however, because this desktop is for deep learning experimentation and therefore I want to tell PRIME to stop using the dGPU for X rendering and leave it free for PyTorch, Tensorflow, etc…

is the answer in these areas ?

or

Thank you

Just use
sudo prime-select on-demand
and reboot. This will render graphics on the igpu and leave the nvidia gpu powered.

1 Like

Done, but still seeing some action on the NVIDIA GPU at idle… is it not expected to vacate the entire VRAM?

The driver gets loaded by the Xserver to stay ready for on-demand rendering. Also disabling this requires additional changes. Please run nvidia-bug-report.sh as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

1 Like

nvidia-bug-report.log.gz.log (364.6 KB)

Please try this:

  • add ‘nogpumanager’ kernel parameter
  • delete /usr/share/X11/xorg.conf.d/11-nvidia-offload.conf
  • create /etc/X11/xorg.conf with contents:
Section "Device"
    Identifier     "intel"
    Driver         "modesetting"
    BusID          "PCI:0:2:0"
EndSection
1 Like

regarding the kernel parameter… you’re meaning something like the following ?

https://wiki.ubuntu.com/Kernel/KernelBootParameters

yes.

1 Like

That did it! Spot on, thank you sir! Cannot let a single byte of that VRAM go to waste you understand… saving my pennies now for something soon.

Thank you!