Ubuntu 20.4 GeForce GT 710 4port HDMI freeze on idle


I am running Ubuntu 20.04 with GeForce GT 710 4port HDMI with 4 monitors.

I have noticed that the system freezes if the system is idle. if I keep playing a youtube video or netflix, there is no problem. The freeze can happen as soon as I login or after I lock the system for few mins/hours.

The system did freeze once while playing netflix, the sound did not stop, but all the monitors (mouse/keyboard) froze. Instead of rebooting, I unplugged the monitor playing the video and plugged it back in. The system did not freeze for days after that, seems like the process kicked something internally.

Please see attached bug report.

nvidia-bug-report.log.gz (262.7 KB)

Any help trying to rectify this would really help. I have tried different drivers. even the latest 465 from the ppa, same issue.

I am running 450 at the moment as I read in one of the forum that this bug is not effecting drivers < 450, but this doesnt seem to be the case.


There are no errors caught in the logs, did you run nvidia-bug-report.sh right after the crash happened?

Yes, I took the output after a reboot as the system becomes unresponsive.

Is there a way to enable debug logging? That might give us some idea.

No, at least nothing that would help in this situation. Please check for a bios update first.
After a crash, is the system still pingable? Can you ssh into it?
Please check if lowering the pcie speed in bios to gen3 or even gen4 helps.

Updated bios to latest v3.10, no luck.

There is no PCIE speed settings on this motherboard.

Computer froze at 11:53:40 & 11:57:02 I grabbed the latest bug report. attached.

I cannot ping or SSH into the system when the freeze happens.
nvidia-bug-report.log.gz (243.6 KB)

Since the system is completely freezing, this rather points to a cpu/mainboard issue. Google gave me a hint this isn’t exactly uncommon owith 3X00 cpus but the solution is unclear, some solved it by

  • setting a fixed cpu clock multiplier instead of auto
  • disabling csm in bios and reinstalling in efi mode
  • disabling c-states in bios
    Of course, all overcllocking settings should be disabled, for cpu and memory.
    Since the system is completely freezing it can’t log anything so it’s a guessing game, unfortunately.

I came across Ubuntu freezes in Ryzen 3000 and X570 - Ask Ubuntu

disabled cstate and no more freeze. No need to run netflix/youtube all the time.

This is a brand new system and I am running bios set at defaults. so almost everything is running at auto (except cstate which is no disabled)

I will monitor this, but I think the issue is resolved.

Thanks for all your help and pointing me to other directions.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.