Ubuntu 24.04 stops booting after running Omniverse Launcher AppImage

After running the AppImage (https://install.launcher.omniverse.nvidia.com/installers/omniverse-launcher-linux.AppImage) to start the Omniverse launcher, but without installing anything from the launcher, ubuntu 24.04 stops booting. Ubuntu is stock 24.04 running the “tested” 535 drivers installed by default.

The message I see when I boot is:

nvidia-modeset: WARNING: GPU:0: BOE Technology Group Co., Ltd (DP-4): G-SYNC Compatible: EDID min refresh rate invalid, disabling G-SYNC Compatible .

that message repeats a few times.

the last message I see is

[ OK ] Started gdm.service - GNOME Display Manager

and it stops at that point.

Before rebooting I noticed that “files” (nautilus) stops being listed in the gnome launcher. There may be other thing that went wrong, but that’s just one that I noticed. What does the AppImage do on run?

This is a lenovo laptop with a RTX3050
nvidia-bug-report.log.gz (341.1 KB)

This seems very strange. Are you saying that your computer no longer boots now ? I cannot see anything in the Launcher installer that would do that. What does this mean ? “start the Omniverse launcher, but without installing anything from the launcher”. Does that mean you have successfully installed the Omniverse Launcher ? And successfully started it, but you have nothing installed ?

You are also mentioning video drivers. This is much more likely to cause a system boot issue. If the drivers are no working for you, you will have to uninstall and try old or new drivers. I don’t think it is anything to do with Omniverse.

The drivers are what are installed by Ubuntu and it works fine right up until I run the app image. I’ve done this three times, and it consistently stops booting after running the app image.

I don’t know how app images work. I just change the permissions so that it’s executable and and run it, log into with my NVidia account, exit and reboot. That breaks the Ubuntu install

Can you capture a video of this with your phone and attach it ? I want to see exactly what is going on. I have never heard of this.

I reinstalled again and found the issue. When trying to run the app image I needed to install “fuse”. But running sudo apt install fuse is what bricks the system. I tried another time and this time I used sudo apt install libfuse2 which let me run the AppImage and it didn’t destroy my install. Thanks for troubleshooting.

I wish I read this earlier:

Warning: While libfuse2 is OK, do not install the fuse package as of 22.04 or you may break your system

1 Like

Ok thanks

I’m experiencing exactly the same issues as described above!!

Well then please follow the above solution. Fuse really affects the install of omniverse.