Omniverse launcher fails to launch

Hi,
Just downloaded the omniverse open beta from nvidia site. However the ominiverse-launcher-linux.AppImage fails to run with the following error …

$ ./omniverse-launcher-linux.AppImage
12:20:41.883 › Omniverse Launcher 1.3.4 (production)
12:20:41.893 › Argv: /tmp/.mount_omnive5nND09/omniverse-launcher
12:20:42.040 › Reset current installer.
12:20:42.051 › Can’t access the /home/shrishan/.nvidia-omniverse/config/privacy.toml file: ENOENT: no such file or directory, access ‘/home/shrishan/.nvidia-omniverse/config/privacy.toml’
12:20:42.265 › (node:275598) electron: The default of contextIsolation is deprecated and will be changing from false to true in a future release of Electron. See [Discussion] Changing the defaults for nodeIntegration and contextIsolation to improve the default security posture of Electron applications · Issue #23506 · electron/electron · GitHub for more information
12:20:43.344 › Running production web server.
12:20:43.353 › Saving omniverse-launcher.desktop file to /tmp/omniverse-launcher-fRS1u4…
12:20:43.353 ›
[Desktop Entry]
Name=omniverse-launcher
Exec=/home/shrishan/Downloads/omniverse-launcher-linux.AppImage --no-sandbox %u
Type=Application
Terminal=false
MimeType=x-scheme-handler/omniverse-launcher
12:20:43.356 › HTTP endpoints listening at http://localhost:33480
[275598:1208/122043.546168:FATAL:gpu_data_manager_impl_private.cc(445)] GPU process isn’t usable. Goodbye.
Trace/breakpoint trap (core dumped

I am on Fedora 35 running with nvidia drivers NVIDIA-Linux-x86_64-470.86.run

Please help.
Thanks.

Hello @shrinath.shanbhag!

Also, another user had the same ENOENT error in this post: Nucleus ENOENT: no such file or directory, open ‘…/launcher.toml’ Error

Here is the solution posted in that thread. Try this out and let me know if it helps solve your problem!

  1. Uninstall Cache
  2. Download Nucleus from NVIDIA Isaac Sim - Getting Started | NVIDIA Developer
  3. Try to install Nucleus on Omniverse launcher then it’s download setup folder in “~/.local/share/ov/pkg/nucleus-workstation-2021.2.4/”
  4. Extract and paste on “~/.local/share/ov/pkg/nucleus-workstation-2021.2.4/” the downloaded nucleus zip (step 2) file except setup folder.
  5. And try to install nucleus again.
  6. Reinstall Cache.

Also, please take a look at our Linux Troubleshooting doc here: Linux Troubleshooting — Omniverse Nucleus documentation

I had the same issue on Fedora 35 in Cinnamon, but logging with Cinnamon Software Mode solved this problem.