"omniverse-launcher" is not responding on new installation

Hello, Nvidia

I tried to install omniverse on my computer, but the omniverse launcher freezes and I cannot see anything in the gui.

My system is Ubuntu 20.04 with the Nvidia driver 470.57.02 for my Geforce 3070. I tried to use:

  1. cleanup tool
  2. –proxy-server
    None of the actions solve the problem. But the launcher for my windows system works well. Can anybody helps me to solve the problem. Below are the screenshots may help you to diagnose the problem, thanks a lot.



best wishes

Hello @juxiaozhu! Sorry to hear you are having trouble installing Omniverse. I have asked the Linux team for help with you problem.

In the meantime, please take a look at our Linux troubleshooting documentation in case it helps. You can find it here: Linux Troubleshooting — Omniverse Nucleus documentation

1 Like

Hi, WendyGram, thank you for you reply, I had been read the link, I tried the Q1 but it didn’t help. And the others are beyond the scope of this problem. Since this is a newly installed Ubuntu 20.04, did I miss some critical dependencies I must install? It would be better if the Linux team can provide a list of dependencies just for the launcher, so I can check my environment. Or what is “privacy.toml”, this file cannot be found.

Regards!

I got the same problem. I am using network proxy: proxychains to lauch Omniverse-Launcher.
I can install Omniverse launcher on the same computer by switching to Win10.
I wish someone can help.

There is an update for omniverse launcher today, so I tried to click Check for updates multiple times, and chose [Wait] rather than [Force Quit] every time the system popped not responding notification. I waited for about 5~10 minutes, and restarted the launcher, it looks OK now!

Or maybe I just updated my ubuntu system via software update.

I don’t know which action solved the problem, but it works now.

I really puzzle by this issue. I did not known whether it is cause by network proxy or the software itself. Are you behind a network proxy or not? @juxiaozhu

I believe it is caused by the software itself, the current version has a lot of bugs, if you go through their codes.

1 Like