Ubuntu Dekstop 20.04 and 22.04 cannot boot after installed nvidia driver ( Tesla T4 )

I tried multiple times , multiple distributions , multiple versions.
Tried 2 versions of ubuntu 20.04 and 22.04.
Try to solve this for 3 or 4 days , please help me !

( Edit 1: The installation was successful , failed to boot)
Installed driver s from Ubuntu Software Distribution , failed .
Run Ubuntu-drivers autoinstall , failed.
Download driver from Nvidia Drivers (510.108.03 and 525 , I forgot the tags) , failed.

Everytime I installed a driver then reboot , I got a black screen , no errors.
Or something like /dev/*** clean , xxx/xxx files , xxx/xxx blocks
After I remove the driver , Ubuntu is able to boot normally.

I did add nouveau to blacklist.conf before install nvidia driver s.

Everything looks just fine when I run nvidia-smi.

I runned startx -- -logverbose in recovery mode.
The system gave up on that.

can only post one link
[Xorg.2.log|attachment](upload://jOlKKNzPA2k3zEf5DEPMAxMCp9T.log) (19.2 KB)

Everytime ubuntu boot without nvidia driver I got a crash about gnome-session.
I dont know if this matters ? I reinstalled gnome-session but it keeps send report.

nvidia-bug-report.log.gz (652.7 KB)