[Ubuntu20.04] nvidia-smi detects no devices (using driver 530)

Our IT told us to update the graphics drivers due to newly discovered vulnerabilities, and after doing

sudo apt remove nvidia*
sudo apt autoremove
sudo apt install nvidia-drivers-530

afterwards, nvidia-smi tells us that there are no devices to be found.
I tried both nvidia-drivers-530 and -open, neither worked with this issue.

It used to work with -470

nvidia-bug-report.log.gz (164.1 KB)


I noticed via

cat /proc/driver/nvidia/version

that I had installed the open driver:

NVRM version: NVIDIA UNIX Open Kernel Module for x86_64 530.41.03 Release Build (dvs-builder@U16-T02-35-3) Thu Mar 16 19:33:35 UTC 2023
GCC version: gcc version 9.4.0 (Ubuntu 9.4.0-1ubuntu1~20.04.1)

Though no matter how, if I did

apt install nvidia-driver-530

it always would install the open driver, so the question is, why does it do that, and how can I install the closed source driver?

Please use Software & Updates to switch to the non “-open” driver version.

And how do I do that without the GUI? I have no graphical interface available on this system, I am just connecting via ssh

Don’t know, if I run
sudo apt install --dry-run nvidia-driver-530
I get the closed driver

Inst nvidia-kernel-source-530
Inst nvidia-dkms-530

sudo apt install --dry-run nvidia-driver-530-open
the open driver.

Inst nvidia-kernel-source-530-open
Inst nvidia-dkms-530-open

Maybe run
sudo apt update

Okay, no idea what the issue was. I installed CUDA 12.1, it came with 530.30, and that driver installed fine. When I updated the driver vs apt install nvidia-driver-530, I know have closed 530.41, the way it should be. No idea why that did not work in the first place, but its working now.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.