Unable to capture frame using Gstreamer

How to enable GStreamer:NO to YES in virtual environment on jetson nano device? We installed python3.6,cuda drivers,opencv 4.7 previously in the main python which is 3.6,how to enable gstreamer in virtual environment?

Hi,
You would need to manually build OpenCV with -D WITH_GSTREAMER=ON. A user has shared a script and please give it a try:
GitHub - mdegans/nano_build_opencv: Build OpenCV on Nvidia Jetson Nano