Unable to flash JetPack 5.1 to Jetson Xavier NX NVMe

I am trying to flash reComputer J2021 Jetson Xavier NX development board using host machine with Ubuntu 20.04 running on Windows 11 WSL.
Unable to flash by SDK Manager as well as by command line.

  1. Command line:
    1.1 when running
$ sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1 \
  -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" \
  --showlogs --network usb0 p3509-a02+p3767-0000 internal

as recommended in Developer Guide
I’ve got the following error:

Error: missing readinfofile (/home/artem/Downloads/nvidia/sdkm_downloads/Linux_for_Tegra/bootloader/readinfo_t234_min_dev.xml).

Please find the full log attached in “missing readinfofile.txt”
missing readinfofile.txt (7.1 KB)

1.2. I noticed that the provided script uses production configuration, so I changed p3509-a02+p3767-0000 to jetson-xavier-nx-devkit and tried again:

sudo ./tools/kernel_flash/l4t_initrd_flash.sh --external-device nvme0n1p1   -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml"   --showlogs --network usb0 jetson-xavier-nx-devkit internal

I got another error:

[   0.6265 ] Stat for MB2BLFILE failed
Error: Return value 19
Command tegrahost_v2 --chip 0x19 0 --partitionlayout flash.xml.bin --ratchet_blob ratchet_blob.bin --list images_list.xml zerosbk
Error: /home/artem/Downloads/nvidia/sdkm_downloads/Linux_for_Tegra/bootloader/signed/flash.idx is not found
Error: failed to relocate images to /home/artem/Downloads/nvidia/sdkm_downloads/Linux_for_Tegra/tools/kernel_flash/images

Please find the full log attached in “Return value 19.txt”
Return value 19.txt (23.3 KB)

  1. SDK Manager
    I’ve got the following error while flashing:
11:26:20 INFO: File System and OS - target_image: Installing BSP Debian packages in /home/artem/nvidia/nvidia_sdk/JetPack_5.1_Linux_JETSON_XAVIER_NX_TARGETS/Linux_for_Tegra/rootfs
11:26:20 ERROR: File System and OS - target_image: chroot: failed to run command 'dpkg': Exec format error
11:26:20 ERROR: File System and OS - target_image: command terminated with error
11:26:20 SUMMARY: Flash Jetson Linux - flash: Depends on failed component

Please find the log attached
sdkm-2023-03-25-11-21-22.log (259.5 KB)

So how should I solve these errors and flash my Jetson?

1 Like

VM is not supported. Please try native ubuntu.

Isn’t it? SDK Manager documentation explicitly states that SDK Manager supports flashing Jetson with WSL. And the errors seems to be unconnected to WSL.

Sorry that I didn’t notice one thing here.

Is this xavier nx or orin nx? You are running orin nx command in your first and 2nd command line…
Please try to clarify which platform you are trying to do here…

Any “t234” board config is for Orin series. And xavier series will be t194. Also, p3767 is the Orin NX module. p3509 is the xavier nx devkit carrier board.

Also, that J2021 looks not a NV devkit. Sdkmanager or our official BSP only supports devkit. For every custom board, please contact the board vendor to confirm if their board requires to use a customized BSP. (If it is, then the board vendor shall provide it to you)

1 Like

And you can also try command “sudo update-binfmts --enable” on your host.

got exact the same results as you did following the developer guide. Also with your changed config jetson-xavier-nx-devkit I got the same error as you.
I´m not able to flash the xavier nx to nvme ssd.

“sudo update-binfmts --enable” doesn´t fix this either.

Are you also using WSL? Or something else?

If you are using something else, better filing a new topic.

using Win11 with VmWare Ubuntu 22.04
Currently trying differnt config file and still running. Seems to be promissing.

Using now flash_l4t_t194_pspi_p3668.xml

Edit: Flash successful, it was indeed the config file in the command
Like WayneWWW already mentioned : for xavier use t194
The developer guide is a little missleading here…


Using now flash_l4t_t194_pspi_p3668.xml

Actually I don’t know what you are talking about… This file cannot be used in flash script as input if you want to flash nvme…

I think you need to clarify what you want to do… There are lots of scenarios that can use on jetson…

From the developer guide it states to use for orin and xavier following command:

I changed *“-c bootloader/t186ref/cfg/flash_t234_qspi.xml”
to “-c bootloader/t186ref/cfg/flash_l4t_t194_qspi_p3668.xml”

and used instead of p3509-a02+p3767-0000 internal

jetson-xavier-nx-devkit internal

The xavier-nx was flashed successful with 5.1.1 with only Nvme SSD installed

edit the typo

1 Like

Looks like there is a typo. There is no “pspi”. Only qspi.

1 Like

yes correct, thanks

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.