SDK manager does not recognize Waveshare Jetson Xavier NX Dev Kit with jetson orin nx as SoM

I have SDK Manager installed in my Vm(Ubuntu 22.10).

Upon connecting Waveshare Jetson Xavier NX Dev Kit with jetson orin nx as SoM, I see the device listed in output of lsusb, and the device is at recovery mode.
Bus 001 Device 003: ID 0955:7323 NVIDIA Corp. APX

But, sdk manager does not recognize the board. Please see attached screenshot.

My goal is to flash the orin Nx with Linux for tegra.
I also followed nvidia quick start guide to do so. I managed to assemble the root filesystem, but when I try to flash the board It fails saying it can not read rcm_state . Please see attached log for more details.

What am I doing wrong, any leads would be highly appreciated.
log.txt (9.7 KB)

Thank you.

The primary issue was I was trying to do this in Ubuntu 22.10 where this procedure is not supported.

I tried to flash using ubuntu 18.10, I did successfully built the kernel and libraries, but it fails while I try to flash the device. I get following error message.

09:49:06 ERROR: Flash Jetson Linux - flash: [ 0.2140 ] ERROR: carveout /misc/carveout/aux_info@CARVEOUT_MCE_COVERAGE/ is not supported

I have attached two logs.
flash-only.txt → using script, flash after pre-building kernel images.
waveshareboard.txt → using build/flash kernel image simultaneously.
waveshareboard.txt (10.6 KB)
flash-only.txt (3.6 KB)

The flash command looks have no sense… did you ever read any document before start doing flash?

Do you want to flash xavier nx or Orin NX or Orin AGX?

waveshareboard.txt → You are using a orin nx board config to flash.

flash-only.txt → totally not sure what you are doing.

log.txt → you are still flashing orin agx.

Also, sdkmanager cannot flash custom board no matter Orin or Xavier.

Please contact the board vendor for customized BSP too.

I am trying to flash jetson orin nx module.
for now only relevant log is in waveshareboard.txt
The flash command i use in waveshareboard.txt → is from the flash guide in waveshare vendors website. They flash command they suggest is as following:

sudo ./tools/kernel_flash/ --external-device nvme0n1p1 \
  -c tools/kernel_flash/flash_l4t_external.xml -p "-c bootloader/t186ref/cfg/flash_t234_qspi.xml" \
  --showlogs --network usb0 p3509-a02+p3767-0000 internal

Yes, i did go through the README_intrd_flash.txt, as far as i understand i have to follow workflow 4.

Does this waveshare board have any “p3509” sticker on it?

I just want to clarify if it is really a NV devkit. Recently there are lots of custom board claims themselves as nv devkit but turns out they are not…

If it is not NV devkit, then back to what I said, you need to contact board vendor.

hmm, it should be or at least they claim to be. this is the website for product description.

Please run the flash command again and dump the serial console log in the meantime.

Thanks for the hint. We don’t get any output through minicom. The FTDI cable works, just confirmed with a Jetson Nano on another dev kit.
What is the expected output? Should we receive anything on a fresh from the factory Jetson when entering recovery mode?

If host side still gives usb timeout error, please enable below on your host machine, flash the board again and check the dmesg on your host.

echo 8 > /proc/sys/kernel/printk
echo ‘module usbcore +p’ > /sys/kernel/debug/dynamic_debug/control
echo ‘module xhci_hcd +p’ > /sys/kernel/debug/dynamic_debug/control


Just a reminder, I expect the uart log start to spew after you start the flash command.

Recovery mode itself will not print any log out.

dmesg.txt (7.1 KB)

Could you provide the host side log too? I mean sdkmanager log.

Also, to make sure your board really can dump log, could you also use xavier nx module and check if you can see the uart log during flash?

hostlog_1.1.txt (11.1 KB) → log from running flash script.
dmesg_1_1.txt (7.1 KB) → dmesg log, after the board was added to vm untill flash script was run

One additional note: on connecting FTDI to vm, dmesg is cluttered by message of following type:

[ 7227.957479] xhci_hcd 0000:00:0c.0: ep 0x81 - asked for 512 bytes, 510 bytes untransferred

I don’t have xavier nx module with me so can not really test it!


I just notice you mentioned VM, is your host machine a ubuntu host VM?

yes, my hostmachine is a vm running Ubuntu 18.04.6 LTS.

The VM is running on arch linux

Sorry that do you have a native ubuntu host? It is common that VM has issue in usb transfer during flash.

yes, i can try this in a different machine!

Also, I tried to flash jetson nano developer kit, during flashing the connection to nano drops and flash script complains that it can not open usb device. I have attached the log, maybe it might be helpful
flash_jetson_nano_1_1.txt (8.5 KB)
to track the problem!

If even jetson nano is not able to get flashed, then it is just as I said, please do not use VM.