Sdkmanager cannot detect orin nx 16GB

Hi,I saw that jetpack5.1 support for orin nx 16GB a few days ago,and I want to use the sdkmanager method to install jetpack on the orin nx,but I found it cannot detect the board in sdkmanager
I can see the module in force recovery mode by typing lsusb on Linux PC,and I have been install linux driver package on this board before,so it is hard for me to found the problem and I need some help

Maybe you can try to dump the log in normal situation and in recovery mode.

When the board is in recovery mode, it will not print anything and respond to your input.

Also, another potential cause is your host machine is a VM and VM always has some detection issue in flashing. You may see it in lsusb, but when real communication starts, it hits other issue.

Also, there is a export logs button on sdkmanager. You can use it to dump host side log.

Same here. lsusb shows Orin NX in recovery mode, but sdkmanager doesn’t recognize board. Bare metal Ubuntu 20.04 PC, no VM.

Just ignore it and continue. NVidia really needs to debug this.

But is was not detected in sdkmanager,can log show about the information about the board?
My hostmachine is Linux PC not VM,and I connect the board by usb,I think it may not be the detection bug

I would like to debug this but could someone share log?

Host side and device side are both needed. Even a “there is no log out from serial console” would help here.

Just want to clarify. I cannot reproduce the issue you are talking about.

Yes ofcouse I will share the log,is it dump by typing the Export Debug logs buttom?I never dump before

Some brief explanation here

The flash process has 2 parts, the host side will send some software to jetson side and start the flash process. Host side communicates with device (jetson) side under this structure.

Some software running on host side and the other software running on jetson side.

“EXPORT LOGS” button on your sdkmanager only provides the “host side” log.
But host side log is not sufficient to debug unless it is a very easy kind of error (e.g. board is not in recovery mode)

To dump the “device side” log, you need to get a usb-ttl cable and follow the setup as this website guides to dump log. This device side log shall get printed in any situation.

This is my screenshot.

Orin NX is connected and in Recovery Mode. SDKManager has just started. Flashing has not begun. No output on the serial console yet. It seems that no logs have been written (or I don’t know where to look). Orin NX is waiting for the PC to connect. lsusb shows the module as 0955:7323 NVIDIA Corp. APX, so there is a connection.

Orin Nano 8G is detected just fine at this step. I don’t have other Orin modules yet.

PC is a Shuttle DH110 with Ubuntu 20.04 and latest updates.

Hi @fchk ,

Could we use manual flash method instead of sdkmanager for your case?

Sdkm will install the BSP folder to your host. Default path should be ~/nvidia.

There will be a jetpack folder and then a Linux_for_Tegra folder in it.

Use the command of (5) and (6) in below document and share the result of what it reports.

minicom.txt (86.5 KB)
I am no sure if it is the right log you want and you can have a look at this file

Hi @MaxineZ ,

What issue do you want us to check here? If you want me to check the flash log, you should put the board into recovery mode and start flash process. Share the log from this console after the flash process starts.

The log you just shared is a boot up log only and your device still able to boot up fine.

But my problem is that sdkmanager cannot detect the orin nx board,so I cannot start to flash,even if I choose the module manually,it will fail,is there any other way to check this problem?Or is there any other way to install jetpack on the orin nx board?


Could you put the board into recovery mode and restart the sdkmanager +flash process again?

Also, share me the console after your board enter recovery mode. Try to enter some text to the console and see if the board can respond to you or not.

For me it is no problem. I can safely ignore the error message, and everything will work. But YOU are going to get a lot of support calls for this.
And this is specific to Orin NX 16G. Orin Nano 8G works fine. Orin NX 8G may or may not work fine (has a different USB PID for 8G and 16G models).

So do you need any help for your issue?

I am fine with many support calls. I am not saying this is totally fine and we won’t have any bug.

But this is a cannot reproduce issue to me. Also don’t know what does that mean you can ignore an error that cannot flash the board. How will you flash the board if host side totally cannot detect your board?

minicom1.txt (184.3 KB)
Here’s the log I got from minicom,I tried set up the sdkmanager manually and start to flash,but it will fail anyway

Hi @MaxineZ

The log seems showing the flash process is already finished. and the 1st boot is already done and waiting for you to configure user account.
Where did you see the flash failure?

Hi @MaxineZ

你的log看起來寫著你已經燒完板子而且燒錄的過程沒有問題… 現在板子在做第一次開機然後在等你設定user account.

請問你在哪裡看到flash失敗的訊息? 可以請你提供host端的log嗎

Yes it seems finished,and I chose the manual way before,so when I tried to setup the second pop-up window(I am not sure if you know what I mean,but in manual way it will pop-up winddow twice),it will fail to connect to the board anway,so I cannot actually sure that the flash is finished

1 Like

Flash is already done. The window is trying to install sdk (CUDA/TensorRT… etc).

Sdk will only be able to sent to your device after first user account configuration is done.

燒錄已經結束了, 你後來在sdkm上看到的視窗是要準備裝sdk (CUDA/TensorRT…etc.)
你得先在你的jetson上設定user account之後 sdkm才能把那些sdk透過 usb port ssh過去.

I login in on the board and start the ssh service,but the window still prompt me that cannot detect the board or cannot connect via ssh