Flash jetson linux - flash error could not stat device dev/nvme0n1 - No such file or directory

Hi all, I was unable to boot up the used jetson xavier so i thought to flash the nvidia jetson xavier nx with the help of sdk manager , when i tried to flash it gave me this error . This is the screensnip of terminal from sdk manager

Are you using Xavier NX devkit or with custom carrier board?
Any external storage connected with device?

I’m using Jetson Orin NX 16G and has a same error. Can you please help?
Uploading: jetson3.png…

Hi @jayashankar2110,
Seems like your NVMe drive is not correctly detected, are you able to use it on other PCes?
Hi @armaniql,
What medium are you using?
Orin NX only supports booting with NVMe SSD/USB drive, so not sure why the /dev/mmcblk1 appears. Or are you using a third-party carrier board?

I’m using host computer(ubuntu 18.04 bionic) and there are already installed packages(Jetson Orin NX 16g SSD), i just power on and set up it and wanted do project,but shows it no has nvidia driver installed i wanted throw the SDK manager install it, and i got that error.

Hi @armaniql, so you are using an NVMe SSD right?
Then did you choose the right option when it asked you where to install the system in SDK Manager?
mmcblk1 should not be available on Orin NX.

So installing folder should be in jetson device,right? I just followed with option what suggested,but the button for HW image folder is unavailable .

Hi, it is where SDK Manager will place the BSP file in your host PC, and it’s not related to Jetson devices.
I’m talking about Step 5 in this guide:
Did you choose the right option for Storage Device?

I’m sorry, but i don’t see step 5 on that guide. For storage i chose SD card .

OK, so let’s get it clear.
What carrier board are you using? It is attached with an NVMe SSD right?
Orin NX does not support neither eMMC nor SD Card, so choosing SD Card should not be feasible.
Or are you not able to find SSD in the drop-down menu?

I’m using Jetson Orin NX 16GB and it’s NVMe with SSD . Yes, i’m not able to find SSD for storage device. In option for storage i have SD, NVMe, USB,Custom.

Well, you should choose NVMe…
As we do not support SATA SSD, NVMe is equivalent to SSD.
Give it a try.

Dave asks whether you have a Jetson Orin NX developer kit, which is composed with an Orin NX module and a carrier board, from NVIDIA not from 3rd party.

Thank you very much Sir. It’s flased succesfully. But got error with USB. It’s not recognising(reading) device anymore. What should i do?

That’s fine, but you should open a new topic if you encounter a new issue.

I opened (Host PC doesnt recognise device(Jetson Orin NX 16G) USB problem) but no replies. I also created long time ago,but also no responses. Could you please have a look?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.