unable to get Oculus Rift recognised on Linux Mint 19 with nvidia geforce 980ti and nvidia driver 4.6.0 NVIDIA 410.79

As stated.

I have one screen connected to motherboard HDMI that works fine. I have one HDMI on the 980ti card where the Rift is connected. The Rift is not shown as connected anywhere.

I have tried setting options in xorg.conf to “AllowHMD” “yes” but mostly, this makes the X server not show picture at all whether or not the Rift is connected.
Deleting the xorg.conf makes the xserver work again.
I have also tried to add a section in xorg.conf.d (that was not present before I added it) with device options to allow HMD. The xserver started and worked normally but I could not see the Rift connected.
I have tried swapping the HDMI socket.

This is on Linuc Mint 19, which is Ubuntu 18.04 based.

Help would be appreciated.
nvidia-bug-report.log.gz (1.06 MB)

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

bug report attached to first post.

Nothing detected at all. Maybe a broken cable or the like. Does it work with another computer?

please check if adding the allowhmd option to
/usr/share/X11/xorg.conf.d/10-nvidia.conf
helps.

Thanks for the swift help.
Oculus headset is now tested in a windows computer. It works fine.
allowhmd option added as you suggest and system restarted. No change I can perceive.
I swapped the HDMI outputs for the screed and oculus and screen is now working on the other one so both connectors are working.

New nvidia-bug-report.log.gz as follows.

nvidia-bug-report.log.gz (1.08 MB)

The allowhmd option is correctly picked up, yet still the oculus isn’t detected. Does
sudo nvidia-xconfig --query-gpu-info
detect it?

Not that I can see, no.

I’ve also tried connecting both screen and rift to the gpu’s connectors, the rift with a displayport adapter but this didn’t help.

To conclude for others what I needed to do to get the Oculus rift cv1 detected:

  • Cover sensor in headset (there is a small yellow light at the bridge of your nose, the light turns off when something is close to the sensor, i.e it thinks the headset is worn)
  • Start openhmd_opengl_example

The headset is now seen as detected.
The OS (Mint 19) was not able to activate the display, but this might come later.
It’s kind of a catch 22 that to have the demo running and headset worn to be detected, because the X server needs to restart to activate the screen, and then the demo is not running.

What is the way around this?

Now that sounds awful. Though I don’t understand why the Xserver needs to be restarted to activate the screen?

Not sure why. nvidia-settings said so when i tried to apply the changes.
Mint native display settings offered to activate it but just gave an error when I tried.

Giving up the rift now.
I borrowed a Vive instead and it worked out of the box.

Godbye Oculus. Hello HTC.