Unable to install decord video reader on Jetson Nano

Hi,

I tried installing decord on Jetson Nano using :

pip install decord

but bumped into an error :

Target Platform is not supported yet.

Any help on either building the package on nano or pip install ?

Thanks

I don’t think making it from source will work either. Jetson uses Nvidia GStreamer API, but most applications expect libnvcuvid (Nvidia Video Codec SDK), which is not available on Jetson. That’s where my attempt to build from source ended. I don’t know how difficult it would be to port the application from libnvcuvid to GStreamer.

hi,
For multimedia usecases on Jetson platforms, we suggest use gstreamer or jetson_multimedia_api. Please refer to documents:

https://docs.nvidia.com/jetson/l4t/index.html#page/Tegra%20Linux%20Driver%20Package%20Development%20Guide%2Faccelerated_gstreamer.html%23

https://docs.nvidia.com/jetson/l4t-multimedia/index.html

Thanks @jeremyshaw1 I tried building it from source with CUDA=OFF on Nano and the build went successful.

I have few CUDA path issues which I am trying to build it again with CUDA support ON.

Thanks @DaneLLL will look at it.

Thanks

@jeremyshaw1 This is what I am getting an error while I try to import :

import decord
Traceback (most recent call last):
File “”, line 1, in
File “/home/sirius/.local/lib/python3.6/site-packages/decord-0.4.2-py3.6.egg/decord/ init .py”, line 4, in
from ._ffi.runtime_ctypes import TypeCode
File “/home/sirius/.local/lib/python3.6/site-packages/decord-0.4.2-py3.6.egg/decord/_ffi/runtime_ctypes.py”, line 8, in
from .base import _LIB, check_call
File “/home/sirius/.local/lib/python3.6/site-packages/decord-0.4.2-py3.6.egg/decord/_ffi/base.py”, line 43, in
_LIB, _LIB_NAME = _load_lib()
File “/home/sirius/.local/lib/python3.6/site-packages/decord-0.4.2-py3.6.egg/decord/_ffi/base.py”, line 35, in _load_lib
lib = ctypes.CDLL(lib_path[0], ctypes.RTLD_GLOBAL)
File “/home/sirius/archiconda3/envs/mx1.7/lib/python3.6/ctypes/ init .py”, line 348, in init
self._handle = _dlopen(self._name, mode)
OSError: libnvidia-ml.so.1: cannot open shared object file: No such file or directory

Any ideas how to get around this ?

Thanks