Unable to install NVIDIA AI Workbench on Windows 10

I have installed:

  • Windows 10 version 1.0.22616.1
  • wsl NVIDIA-workbench
  • Docker version 4.27.2
  • GPU Nvidia Gforce RTX 3080 Ti
  • CUDA toolkit 12.2
    When I run the installer, I select Docker as the container, apply yes to UAC screen, and then I get the “Waiting for Administrator Privileges” screen, and the process gets stuck in this screen. It seems that the installer cannot get authorization from the system, even though I had granted access using the system prompt that opened.
    I tried running as administrator since the beginning, using the “Run as Administrator” option, but when I start the application as administrator, nothing happens, I mean, it does nothing.

Hi Carlos,

Docker is a new runtime and we are still working out some issues for it. Podman is the most robust container runtime on Windows at the moment.

In addition, the install process on Windows is fairly complicated and it isn’t yet open to “DIY” approaches.

A potential solution to your problem here is the following:

  • Use the podman runtime instead. Note that podman is not installed system wide and is restricted to the NVIDIA-Workbench WSL2 distribution. There is no worry about it interfering with your system.
  • If this solution works for you, then do the following:
    • Go into the ..AppData/Local/NVIDIA Corporation/AI Workbench/registries folder on the Windows side.
    • Delete the workbench-config.json file.
    • Go back to the Desktop and double click the Workbench icon to resume the installation at the container runtime select.
  • Note, if you configured your Git server integration, i.e. GitHub, then you should skip trying to configure it again. You will get an error.
    • You can remove that issue by using the CLI to disconnect the GitHub integration and then reconnect it.
    • Procedure would be nvwb disconnect integration in the CLI
    • Then, in the CLI you can run nvwb connect integration and select GitHub and complete the flow.

Let me know if this works.

Tyler

Hi @twhitehouse
Based on your suggestion, I tried to use the Podman option, but the result is the same, I mean, the installation gets stuck in the “Waiting for Administrator Privileges” screen, in the same way when I select Container. This way, it is not possible to install the Workbench on my Windows 10 because none of the two container options works.
I even set up the installer with admin privileges, before launching the installer, but still the same result and no success.

Ok. I’m sorry to hear this.

It would be helpful to see the logs.

If you go into ....\Users\yourname\AppData\Local\NVIDIA Corporation\AI Workbench\logs you will see a file called main.

You can attach it to a reply here, or you can email it to aiworkbench-ea@nvidia.com.

This will help us diagnose.

Hi Carlos,

I’m checking back in to see if this every got resolved.

There is a GA version of Workbench that is much more robust to install.

you can get it here.

Sincerely,

Tyler