Stuck on waiting for Administrative privileges

Which Workbench location had the issue?

local

What is the Operating System for your local Workbench?

Windows 11 home

What is the Workbench Desktop App version?

0.28.29

Was the issue with the Desktop App or the CLI?

Desktop App

Summary of the Issue

It asks to select a container runtime and when I select either of them it asks for permission, the UAC pop ups and after clicking on yes it gets stuck on the same page showing "Waiting for Administrative Privileges " and then after some time it shows Application Error. Also, no system prompt is opened. Even tried running the application as Administrator.

What are the error messages?

Waiting for Administrative privileges → Application Error.

What are the steps to reproduce

After completing download of WSL2 and restarting, during selection of Container Runtime

Upload screenshots or logs

Hi

sorry for taking so long to get back to you.

can you try to install the latest GA version?

you can get it here.

Tyler

Hi, I have tried installing the latest version and still facing the same problem. No system prompt is opened!!

Got it.

Can you please attach the main.log file that you can see in
C:\Users<username>\AppData\Local\NVIDIA Corporation\AI Workbench\logs\ ?

Thank you for your message. I am attaching the main.log file as requested.
main.log (533.9 KB)

Hi

Once you got your OS updated to something supported, things seem to go well until Admin privileges are required and the offered password doesn’t work.

  • Are you sure you have permissions to install things locally?
  • Can you give more context on who administers your laptop?

Tyler

Hello,

  1. Yes, I have the necessary permissions to install software locally on my laptop. I have ensured that I have the correct user privileges to make changes or installations on my system.
  2. I am the sole administrator of my laptop. I have full control over the system settings, software installation, and user account management.

Ok. We have a few other users with a similar issue.

We are going to collect data and look into it.

Will get back to you.

Thank you very much for your patience.

1 Like

Typically this rejected admin password is the result of some unfinished Docker Desktop for Windows setup. Have you installed Docker Desktop for Windows? If so open the application and complete the setup questions. After that AIWB should handle the container mgmt.

Hello, I encountered the same issue while experimenting with both Podman and Docker.

On closer inspection, sorry I did not notice this before. You are running Windows-32 version 6.2 We are supporting Windows 10 v19045 and Windows 11 because of necessary WSL support required by the product. Do you have a Win11 machine with WSL feature enabled?

Hello, sorry for the late reply. If you’re referring to the operating system, I’m undoubtedly using Windows 11 Home on an x64-based PC, which supports WSL2.

I should also mention that I once attempted to run the application in Windows 8 compatibility mode.

Ok. Sorry to take so long to get back to you.

It’s possible something got in a weird state when you tried to install with admin privileges. I note that you switched to non-admin at some point, but perhaps that wasn’t enough.

Can you try a manual uninstall of the application and then run the installer again for a fresh install without admin privileges?

You can see uninstall instructions here: Windows Uninstall - NVIDIA Docs