Application Error, Unable to install

Please provide the following info (tick the boxes after creating this topic):

Submission Type
[*] Bug or Error
Feature Request
Documentation Issue
Question
Other

Workbench Version
[*] Desktop App v0.44.8
CLI v0.21.3
Other

Host Machine operating system and location
[*] Local Windows 11
Local Windows 10
Local macOS
Local Ubuntu 22.04
Remote Ubuntu 22.04
Other

Windows Version:26100.751
Processor: Intel 13900KF
Card: RTX4090
RAM: 96GB

I am trying to install AI workbench for several times, searched on forum several times and tried all the solutions not working. Preinstalled the newest Ubuntu, WSL2.

wsl -l -v
NAME STATE VERSION

  • Ubuntu Stopped 2
    NVIDIA-Workbench Stopped 2

main.log (33.9 KB)

Hi,

I’m seeing the following in the logs:

[2024-06-07 18:54:42.957] [error] (check-host) Command failed: wsl -u workbench -d NVIDIA-Workbench – /home/workbench/.nvwb/bin/wb-svc -gid 1000 -uid 1000 info
failed to load server info. try again: failed to load host state: Failed to check gpu state - you may need to restart you computer to reload drivers: exit status 1
[2024-06-07 18:54:42.958] [info] (renderer) SERVICE: hostCheck(), CHANNEL: check_host
[2024-06-07 18:54:42.958] [error] (renderer) error.platform.installer.get_initial_state:invocation[0] {
type: ‘app_error’,
data: { message: ‘Something went wrong please restart your installer’ }
}

Looks like AI Workbench is unable to detect the status of your GPUs. Assuming you have installed GPU drivers already, you may need to reboot your system to reload the drivers. Try that and see if it helps.

That is strange, I installed the lastest 4090 driver and Cuda 12.5, rebooted several times. Always the same issue.

Have you tried to update Workbench?

From your initial message it looks like you are running an older version.

To update, go into your system tray and right click on the grey NVIDIA Workbench icon. Select check for updates.

Thanks for the reply, I will try to uninstall all the driver and install the CUDA 12.5 built in driver. Install the newest version AI workbench. Will try again. Thanks for the help.

Seems like its still not working. Uninstalled every Nvidia related software and reinstalled the driver, CUDA, and newest workbench (Version 0.50.17). However, still get application error. I’ve attached the log again. Sorry for interupting.
main.log (56.9 KB)

Please don’t apologize!!

We will inspect and get back to you. This could be a bug.

Thanks a lot. Maybe a potential cause is I’m using Windows 11 LTSC 2024?

Got it. We don’t support this version currently.

So basically it is Windows 11 Enterprise 24H2. [26120.770]
Maybe I will wait for an update.

Can you send the workbench.log file? It will have more info.

You can see how to get that log file here.

Thanks a lot. Will upload the log when I come back home.

We need to see the details of the WSL2 setup because WSL is preventing AI Workbench from properly installing. Please send wsl -v cmd output. Have you already installed Docker Desktop on this workstation? wsl --update should fix the wsl installation.

Hello, this was the outout:
wsl -l -v
NAME STATE VERSION

  • Ubuntu Stopped 2
    NVIDIA-Workbench Stopped 2

I uninstalled wsl2, installed again, and my wsl2 was already the newest version.

I will send out the workbench.log when I come home. Really appreciate for your help!!

workbench.log (717 Bytes)

main.log (101.5 KB)

Here’s the workbench info and newest main.log. It seems like its always not detecting the gpu state. However, I installed the latest CUDA 12.5 driver with built in display driver (clean installation).

Seems like there’s also podman issue, I’m installed lastest version of docker.

Also, my wsl2 is newest version with Ubuntu 22.04 installed

Seems like in the latest windows 11 24H2 build, they removed the essential WMIC.exe feature which Nvidia AI workbench needs. Is that possible to have a update to solve the issue? Microsoft already released the 24H2 builds.

Thanks for the help.

Good find. Pretty sure you are correct here. We are using wmic.exe in 1 spot where we look for installed GPU cards even in the case the drivers aren’t installed or installed incorrectly.

We do test on Windows 11 Insiders, but for some reason we didn’t see this failure. We’ll have to go dig into why.

But yes - simple fix and we’ll get it out in the next release. Thanks!

The strange thing is that seems like win 11 24h2 upgraded from 23h2 will have wmic remained. However, for freshly installed win11 24h2, the wmic is totally removed.

That might be the reason that the bug was not found on 24h2.