Unable to install NVIDIA CUDA Version 11.3

Following is the information when I see the installation failure:

  1. NVIDIA CUDA Version 11.3 fails to install Nsight Visual Studio Edition.
  2. Most of the components in the list are “Not Installed”.
  3. Only four items are installed: Visual Studio Integration, Nsight systems, Nsight Compute and Nsight NVTX

Note: I tried following options from my end:

  1. I have Visual Studio Professional 2019 Version 16.7.5 installed and my computers’s operating system is Windows 10 Pro.
  2. I applied Windows updates and restarted my computer.
  3. I also tried uninstalling all the NVIDIA components and restarted my computer before doing a second time installation.

Hola como estas?, a mi también me pasa lo mismo que a ti, instalando Cuda versión 10.1 updated 2, con targeta GeForce GT 1030

Hola como estas ?, a mi también me pasa lo mismo que a ti, instalando Cuda versión 10.1 updated 2, con mi targeta grafica GeForce GT 1030

Thank you for the suggestion. I was able to install CUDA 10.1.2. However when I started building the code it didn’t load solution with CUDA and looks like I need to have CUDA 10.2. When I tried installing 10.2, it failed at Visual studio integration and doesn’t install any of the components. Does anyone have any idea on what is going on?

Hello, the same thing happened to me with cuda 10.1 updated 2, visual studio integration did not install, but they recommended me to install cuda 11.3 updated 1:

I was able to fix the issue and mentioned this here:
Cuda 10.2 installation failed for visual studio integration - CUDA / CUDA Setup and Installation - NVIDIA Developer Forums

Hello, how are you? I was able to install cuda 11.3 update 1
Best regards
the visual studio integration, installs smoothly on Cuda 11.3 update 1