Unable to load 'arch/fourier_net'


I’m trying to run the code in the exercises in the Nvidia course [Introduction to Physics-informed Machine Learning with Modulus] The chip2d exercise on my A100 GPU. It is showing me this error unable to load ‘arch/fourier_net’ and I’m not sure why.

Try using just fourier as the documentation has a typo as noted in the bottom of this comment:

1 Like

Hi @merza-ali

If you are following the DLI course, please use the versions 22.07 or 22.09 (container available on NGC registry) I believe for complete consistency. Newer versions have slightly updated imports when we went OSS. Mapping should be pretty straight forward to figure out if you’re using a newer version of modulus. Thanks!

I have tried to use the fourier arch but still having the same issue. It can’t seem to find the correct path of the arch. I’m not sure how to specify the search path

I tried upgrading to the latest version and I’m still having the same problem. It still can’t seem to find the correct path. This is where the arch is located “Path: :/scratch/awn5175/ModExamples/modulus-sym/modulus/sym/models” but it seems it is searching in the wrong path.

Hi @merza-ali

Sounds like there’s an issue with your python environment? Are you using a docker container, pip install, conda env? Modulus source code should be installed in your dist-packages folder Python uses, not in examples folder.

Hello, I used pip install with a conda env. How can I check where is modulus installed? The examples folder is the directory I created to store different examples.

Python packages are typically found inside your environment folder of your conda install. Something along the lines of:

<path/to/conda>/envs/modulus/lib/python3.10/site-packages/

You can quickly file where a given python module using __file__ property on the module. For example, using python in the console:

python

>>> modulus.models.mlp.fully_connected.__file__
'/<path to my packages>/modulus/models/mlp/fully_connected.py

I have checked where the packages are installed and they are in the correct place. I tried running a different example and it worked fine but when I try to run that example. The error above is shown. I’m not sure why it can’t find the correct path for the fourier_net model. I ran one of the examples of modulus earlier and it worked fine. When I try to run this example it seems it’s looking in the wrong path for the cfg file or for the fourier net model as shown in the error above.