Unable to see login screen on terminal ttyTCU0 - Jetson AGX Orin

We are unable to see the login screen on the UART3 terminal ttyTCU0.However we can see the boot log on the same terminal. Once board is booted up we are not able to see anything.

Even when we tried
“echo “hello” > /dev/ttyTCU0”
we couldn’t see any print on the terminal.

We have done the below changes
In file “tegra234-cvm-p3701.dtsi”
chosen {

  •   bootargs ="console=ttyTCU0,115200";
  •   /* bootargs ="console=ttyTCU0,115200"; */

In file “p3701.conf.common”

-CMDLINE_ADD=“mminit_loglevel=4 console=ttyTCU0,115200 console=ttyAMA0,115200 console=tty0 firmware_class.path=/etc/firmware fbcon=map:0 net.ifnames=0 nospectre_bhb”
+CMDLINE_ADD=“mminit_loglevel=4 console=tty0 firmware_class.path=/etc/firmware fbcon=map:0 net.ifnames=0”

As per kernel_tegra234-p3701-0000-p3737-0000.dtb file the UART is enabled
serial@c280000 {
compatible = “nvidia,tegra194-hsuart”;
iommus = <0x03 0x04>;
reg = <0x00 0xc280000 0x00 0x10000>;
reg-shift = <0x02>;
interrupts = <0x00 0x72 0x04>;
nvidia,memory-clients = <0x0e>;
dmas = <0x05 0x03 0x05 0x03>;
dma-names = “rx\0tx”;
clocks = <0x02 0x9d 0x02 0x66>;
clock-names = “serial\0parent”;
resets = <0x02 0x66>;
reset-names = “serial”;
status = “okay”;
phandle = <0x37e>;

Is there any other change that we need to do.

Hi vbhm,

Are you using the devkit or custom board for AGX Orin?
What’s your Jetpack in use?

May I know what’s your usecase?
/dev/ttyTCU0 is Tegra Combined UART which could output the debug messages from MB1/bootloader/Kernel and enabled by default.

If you are using the devkit, do you connect the mirco-USB port.
Please also refer to the following instruction to capture the serial console log.
NVIDIA Jetson Orin - Serial Console - RidgeRun Developer Wiki

Hi Kevin,

We are using custom board.
Jetpack Version - 35.4.1

Use case: we wanted to use ttyTCU0 for logging into the device. We are unable to see the login prompt on the same.

Do I need to disable combined UART for that?

It should be enabled by default. Debug messages and serial console are available on /dev/ttyTCU0. From your host, it should be detected as /dev/ttyACM0.
Do you have any custom HW design difference from the devkit?

Hi Kevin,

Issue got resolved by disabling UARTC (0x0c280000) and enabling combined UART.
Also, Included the below highlighted lines in file “nvgetty.sh” in path “Linux_for_Tegra/rootfs/etc/systemd”

if [ -e “/proc/device-tree/compatible” ]; then
CHIP=“$(tr -d ‘\0’ < /proc/device-tree/compatible)”
if [[ “${CHIP}” =~ “tegra194” ]]; then
setsid /sbin/getty -L 115200 ttyTHS0
elif [[ “${CHIP}” =~ “tegra210” ]]; then
setsid /sbin/getty -L 115200 ttyTHS1
elif [[ “${CHIP}” =~ “tegra234” ]]; then
setsid /sbin/getty -L 115200 ttyTCU0

i have same issue, could you please provide me a detailed solution?
How can i disabled the UARTC and enable combined UART?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.