Unexpected behaviour when trying to login at DLI

when i try to login in order to use courses, it asks me to accept Eula and then when i click on accept, it returns back to login page again!

Hi @Bahman

I have forwarded this issue to the DLI team to investigate.
Thanks for your patience,


Hi @Bahman can you please provide a screenshot of the last page you see before you get redirected to the login page so I can try to help resolve this for you?

Hi @tdahlin,
When i enter my email address and password, this is the last page I see:

And clicking accept returns you to which page exactly? The one you enter your email address on?

@TomNVIDIA Thanks so much!

yeah exactly, this page:


What page are you visiting originally to try to login at? Are you going through https://courses.nvidia.com/join or courses.nvidia.com/dashboard to login?

both is same really, there is no difference. it doesnt let me to get into account!

^ that one is my account as well. i cant login with both accounts! no matter which link i use!

Have you tried logging in using an in-cognito tab already? Sometimes browser plugins will cause issues by blocking or changing elements, and using an in-cognito tab can help with this.

Thanks so much, yeah incognito tap did it!! I appreciate it!

Glad to hear that worked! If using an in-cognito tab resolved the issue for you, there are a few things you can try to get it to work when you are not using an in-cognito tab:

  1. Clear your cache and cookies. Occasionally, due to the complex account systems that we have, your session can end up in a weird state that can cause unexpected behavior, and clearing your cookies and cache can help.
  2. Experiment with disabling and enabling browser extensions until it works. Usually, if a browser extension is causing a problem like this, it’s a privacy-focused plugin that’s being a little too aggressive. You should be able to disable these plugins on a per-site basis, so you shouldn’t need to uninstall anything.

Hi again, I tried everything you said but I can only login via incognito tab. I have tried already 3 different PCs, but all have same behaviour! But It’s ok, I can access to the course with that trick! Thank you for everything!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.