Unhandled Exception in EL3 error after AGX Xavier reset

Hi,

Also want to know, if you use same board/module with jetpack4, will you hit this issue?

I will download and install jetpack 4.6.1 and give it a try.

Thanks,

jetpack_4_logs (4.9 KB)
I dowloaded jetpack 4.5.1 and tried it.

The logs are attached. It hangs in there saying HALT: spinning forever.

There is no jetson-agx-xavier-industrial so I used jetson-agx-xavier-devkit conf on our custom, not sure if that is what is messing it up.

But after a powercycle when it is in the HALT:spinning forever stage , it goes back to the old UEFI
Jetson UEFI firmware (version r34.1-975eef6 built on 2022-05-16T20:58:45-07:00)
ception in EL3.R 0x80000000: exception reason=0 syndromeUnxbndl0000
x30Unhandled Exception in EL3.
x30

I don’t think the jetpack 4.5.1 flash flashed into the mmcblk0p1.

Thanks,

Hi,

AGX industrial added to support in jp4.6… so you should at least use version >=jp4.6…

I tried 4.6.1 sdkmanager and it downloads sdkmanager_1.8.1-10392_amd64.deb which once installed goes to 5.0.1 version.

The sdkmanager which seems to work for is sdkmanager_1.6.1-8175_amd64.deb.

From the list which one would you suggest I use

sdkmanager_1.8.1:
deb | rpm | Docker image 18.04 | Docker image 20.04
sdkmanager_1.8.0:
deb | rpm | Docker image 18.04 | Docker image 20.04
sdkmanager_1.7.3:
deb | rpm | Docker image
sdkmanager_1.7.2:
deb | rpm | Docker image
sdkmanager_1.7.1:
deb | rpm | Docker image
sdkmanager_1.7:
deb | rpm | Docker image
sdkmanager_1.6.1:

Thanks,

Hi,

You don’t need to downgrade “sdkmanager version”. Sdkmanager 1.8.1 can also install jp4.x.

But the problem is jp4.x can only be flashed by ubuntu 16.04 and 18.04. Thus, if you see sdkmanager have no option for jp4, then it probably means your host version problem.

BTW, why are you still asking me how to flash jp4? Is this your first time doing bring up for custom board and you directly try with jp5 only?

The linux host is 18.04 details below.
[cornet@cornet-HP-250-G5-Notebook-PC ~]$ uname -a
Linux cornet-HP-250-G5-Notebook-PC 5.4.0-122-generic #138~18.04.1-Ubuntu SMP Fri Jun 24 14:14:03 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
[cornet@cornet-HP-250-G5-Notebook-PC ~]$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 18.04.6 LTS
Release: 18.04
Codename: bionic
[cornet@cornet-HP-250-G5-Notebook-PC ~]$


If I install the 1.8.1.10392 it is install JP 5.0.1 version. Once I install sdkmanager_1.6.1-8175_amd64.deb I was able to install JP 4.5.1

Within the nvidia folder I have the following folders which has a flash.sh which I use
ls nvidia/nvidia_sdk/
JetPack_4.5.1_Linux JetPack_4.5.1_Linux_JETSON_AGX_XAVIER JetPack_5.0.1_DP_Linux JetPack_5.0.1_DP_Linux_JETSON_AGX_XAVIER_TARGETS

There was no choice to use 4.6.1 for sdkmanager. It directly went to 5.0.1

For our custom board we directly started with 5.0.1. We downloaded the latest sdkmanager from nvidia and proceeded from there. The only time I use jp4 was when I downgraded sdkmanager to sdkmanager_1.6.1-8175_amd64.deb and that install JP4.5.1

Would this have anything to do with EEPROM. We have zeroed out the cvb as you had suggested early on. Are there any hardware leads that we can look at to see why a powercycle might affect it. Thirdly why would a BCT partition reflash correct the issue ?

Thank you again for your patience and all the help.

If you run sdkmanager --archivedversions for your sdkm 1.8.x version, will you see the jp4 version?

For your rest question, unfortunately I cannot answer.

I can only say

  1. You are using a preview version software which we don’t know if it would have some new bug or not. That is why I suggested you to try jp4.x which is more stable version.

  2. However, because you are using your own custom board, we can only ask you to check the design guide for your hardware first. I am no hardware guy so have not much to suggest. Maybe check the power sequence.

  3. BCT partition may be periodically being dead on your board for some unknown reason. Which we have no idea.

  4. CVB eeprom has nothing to do with your issue.

  5. There is no other partners or customers reporting such issue to us in the past 2 months after jp5.0.1 release.

jetson_4_6_1_logs_after_powercycle (46.1 KB)
I tried your suggestion of using archivedversions and I upload 4.6.1 to our custom board. What is different from 5.0.1 is that we do not see any display on DP0 which we could with the default jetson-agx-xavier-industrial configuration.
But on powercycle on jetpack 4.6.1 does not crash. the logs are attached.

Please let me know how to proceed. Would jetpack 4.6.1 is something we would need to build on and not use 5.0.1.

Thanks,
Ram

Please try more test to make sure that crash on BCT partition really does not happen.

Also, there would be a new jp5 release this week and you may also try that version.

We tried to modify the 4.6.1 with the pinmux files generated by spreadsheet version 1.4 (.dtsi files that works on the version 5.0.1) and modified the code for the Xavier Industrial followed the bring-up guide v1.2 but nothing works (no display on any DP port) after the code flashed to the Xavier on our custom board. Is the 4.6.1 works with the Xavier Industrial and custom board?

Hi,

This thread is just to clarify the crash in UEFI. So I only want to check that issue. The peripheral issue should not be discussed here.

Also, “every” jetpack release by default only supports devkit. If you want to make it work on custom board, multiple modification and debug may be needed. This is not just “does this version support custom board?”.
If you don’t know how to debug or modify device tree, then every release does not support custom board.