Unity: Issues with OpenXR Render Mode MultiPass, Using Oculus Quest 2 with the APK from the NVIDIA SDK

I have a strange issue with Multi Pass rendering with my software. In VR, if I use Multi Pass rendering the view gets stuck in a jittery hell and does nothing but stay stuck in VR, VR is running fine when looking at the monitor VS on the headset.

Using latest version of OpenXR. Runtime set to SteamVR.

If I set Rendering Mode to Single Pass Instance it jitters sometimes but 8/10 it works just fine, bad part is that the way that the cameras and objects are set up, Single Pass Instance only shows my objects on the left eye VS Multi Pass on both eyes.

Is there a best practice or a check list of settings I need to make sure are correct to get CloudXR to work correctly in these instances?

Thanks for all your help!

Best Regards,
Jonathan R.

@GJones-NVIDIA-XR-Team I saw you are active in these threads, would you know what could be causing my issue?

Thanks in advance!~

Hello Jonathan,

please keep in mind, that the OpenXR path of SteamVR is currently not supported by CloudXR. It might work, but isn’t tested on our end.

That being said, did you verify that your application works as intended with SteamVR and OpenXR using an HMD connected to the PC directly (e.g. HTC Vive) to test if this is CloudXR specific?

What graphics API are you using?
Did you test existing VR applications with CloudXR? Other OpenXR applications in your setting?

Kind Regards,

Just a data point: Native OpenXR app running through SteamVR’s OpenXR runtime going through both VirtualDesktop and CloudXR 3.0 / 3.1 / 3.2 all works for me.


It seems the issue lies with Unity itself!

If using OpenXR via Unity with Multi Pass Rendering it will make it unusable in the Editor.

If it’s a build with the same settings it works flawlessly.

It could be that using the Editor in Unity while using CloudXR to stream it to the headset is in no way an ideal setting.