No controller input when streaming to Quest 2


I wanted to try out CloudXR using basic Unity app which is then built for Quest 2. Server and client app are running with no problem. I am using Unity 2020.3.33f1 and XR Interaction Toolkit. I just added the SteamVR plugin to the project and made sure that OpenVR Loader is checked in XR Plug-in Management in Project Settings.

My app is streaming to Quest but I cannot get any input from Oculus Touch controllers. I can see the controllers in the scene as well as their position and rotation but pressing any button isn’t doing anything. Meanwhile, the app is working when I build .apk file directly for Quest.

I looked through the project and found that there is no bindings_oculus_touch_controller.json which is mentioned in cxr_controller_actions.json, but there are some others like bindings_index_controller.json.

Can you help me with some answers as to how I can solve this problem and get input from controllers?

Thanks in advance!


I also tried to create my own bindings_oculus_touch_controller.json, but nothing I tried works…

Hello - from a discussion with our engineers: Neither Valve nor Unity support using the XR Interaction Toolkit with the OpenVR plugin. Both recommend switching to the OpenXR plugin. This will require setting the server SteamVR to be the system OpenXR runtime.


This solved the problem, thanks for your help!

Absolutely, thanks for posting!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.