CloudXR: Not getting a Video Feed! Even though head tracking, controller motion, and audio stream is working

Hi there!

Our setup:

  • Windows client: We have gaming laptop (intel i7 9th gen) with a Nvidia GeForce RTX 2070. We have of course installed is the CloudXR Client (v3.2.0).
    - Headset: On the above Client we connect an Oculus Rift S headset (i know it isn’t written as supported but we wanted to give it a try ) and we also tried with a Google AR compatible Phone and respective Cloud XR client sample APK.
  • Second client, we also have a Android AR SDK compatible Android Phone with Google AR kit and sample apk app installed. And we have tried both the options (devices mentioned above - HMD and Android phone each but have failures for both paths)
  • Server: a windows machine with CloudXR server installation (v3.2.0) and Nvidia A40 GPU
  • Network connection: the server and client are connected via a VPN, we have ensured all ports mentioned in FAQ are opened/accounted for

Connection Procedure:

  • We start SteamVR on the Server.
  • We connect the Oculus headset to the client
  • We start SteamVR on the client (ensure the headset works)
  • We run the client executable CloudXRClient.exe app that comes with the SDK.
  • The client successfully connects to the machine. We see in the terminal “video stream created successfully”, “video stream created successfully”, “audio recieve stream created successfully”, “input stream created successfully”, “input stream connected”.
  • Then we get a constant output of FPS and Latency readings in the terminal. SO it seems to be working.
  • We see on the Server side that the SteamVR detects the headset and shows a running application.


  • Throughout running a VR application on the Server Side, either the SteamVR Tutorial application, or the Autodesk VRED application - there is NO VIDEO FEED! The only thing visible while wearing the headset is a blank green/turquoise screen. We can’t see hand models. But can hear that the audio works in the headset.
  • But strangely everything else works on the server side: We have head tracking working since i can see in the SteamVR Tutorial (server side) the camera view follow my movements as i move my head while wearing the client-connected headset. But head tracking doesnt work in the VRED application.
  • We can see hand models for my controllers follow my hand movements in both applications server-side! (when its said server side - its the Autodesk application in one case, and Stream VR streaming application sample in second case)
  • And we can hear all of the audio from the server side from within headset! (especially for the Stream VR streaming application example, for Autodesk demo we dont have any audio so for sure its silent )
  • But again, no Video Feed towards the headset.

Would appreciate if there are any pointers for us to dwell into which enables us to fix this? Since we are noobish to this landscape we want to run with some vanilla helloworld cases to get a hang of running system before we go into our specific dev and tests…though we cant seem to get basic Hello World up and running :(

So any pointers on what we should look at would be appreciated ( we have spent some fair bit of time reading documentation etc though for sure we are missing something basic). Thank you very much for your time!

Exact same Issue here … i also get sound out on the headset … and i see head tracking working on the CloudXR server (through RDP connection)

Yesterday i hit one pointer on “NVIDIA CloudXR Server — NVIDIA CloudXR SDK documentation

It states that " Microsoft Remote Desktop (RDP) is known to be incompatible with CloudXR, and it causes side effects such as a green video stream, and sometimes, network connection issues." And atleast we were using RDP to connect to the Server VM to check SteamVR status etc. So we in our lab intend to switch to VNC and test it again…But may be @stefan.sigl you also want to get away from RDP.

in the mean while if anyone else on forum has more pointers for us, drop a note here please

Oh wow … great hint … Thank you … that was the issue for the green screen. (just had to disconnect RDP)
Now i have no audio though ^^

on our side as well, its a bit shady
Case 1 → we did shutdown the RDP service. And setup VNC…end result, SteamVR on client crashed at connection and SteamVR on server side completely went in untouchable state. Takes like 5 min to get back to usable state, but complains “a key component of Steam VR is not working”. Restart the machine and exactly same situation

Case 2 → we didnt shutdown RDP, but did not connect over RDP either and used VNC instead, now everything comes up and we can see Steam tutorial/inbuilt demo application on HMD. Hurray…but that was a quick celebration. Shut down and tried again, again Steam VR stuck…so its 1 out of 3 times post a restart things work (very unpredictable).

and we are wondering the problem we hit for case 1, might be two of three occasions where it doesn’t work for case 2.
We repeated case 2 with ARClient using Samsung Galaxy S21…well same behavior. Server side Steam VR got in hung state and then “a key component of Steam VR is not working”.

@stefan.sigl did you turn off RDP or just didnt use it??

Actually i used RDP to start SteamVR and the Application then i got the effect that i had greenscreen on the client but saw the headset movement on the server … then i disconnected from RDP and the greenscreen on the client disappears and i can start using the app but with no audio

okay but if i do not have a RDP Connection on start i again have a green screen … so i have to have a RDP connection when is start the Client connection … and then disconnect RDP then it works … have to investigate more

@stefan.sigl so in short you didnt disable RDP on Windows server. That is what i wanted to understand… thanks for clarifying. And adding RDP connected at start, we have had partial success with that and without. There is no pattern or predictability when it works and when it doesnt is hard to comment on :D (Atleast on our setup)

We would keep experimenting later today…am thinking of creating a small table with all scenarios lol

Just to close the thread, so that future readers DO NOT go through the same issue.

After a lot of back and forth and analyzing logs, we ended up reinstalling everything (XR SDK Server/Client, Steam and Steam VR) and it started to work. We have witnessed once every few occasions where Steam VR on startup would through that it is encountering an error and when that happens we followed the advice here " Steam Support - SteamVR - Error messages (" around fix Steam VR installation path by running vrpathreg.

So crux is, when you dont know what is happening

  1. Make sure you do not RDP into windows machine which is acting as Server - this i think was our major issue ( we initially stopped RDP, but in some permutation / combinations we tried keeping it on but not use it and it was fine).
  2. Try reinstalling things (XR SDK and Steam)
  3. Do not, i repeat do not trust the example clients packaged in XR. Take the source and rebuild them for your target platform (e.g. the packaged AR Core based Android (apk)client, didn’t worked on any modern Phone like Samsung S22, till we rebuilt it with appropriate libraries/dependencies)

We also got the Android ARCore Client to work as well! Im posting this here for other future readers to see:

The solution was similar to the one before. We are running the client on a Samsung S21. The key this time was to re-built the Android client APK with the correct matching ARCore/OBOE libraries and build it for ARM64. RDP was enabled, but was not used. Instead used TigerVNC to control the server.

If you encounter an error getting this to work. You should:

  1. re-build the client apk by find a configuration of platform/ARCOre/ OBOE and other libraries that work.
  2. re-install Cloud XR server, Steam and SteamVR.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.