CloudXR server isn't running when I launch SteamVR

CloudXR server isn’t running when I launch SteamVR.
What do I need to provide so that someone can help me fix it?

CloudXR is installed as a plugin within SteamVR. Can you verify it is listed within SteamVR’s plugins?

Sure, here it is.

Thanks. Then you’re good to go and it is running if set to On. The “Headset Not Detected” can be ignored and goes away when you connect a client. You can also verify server is running by looking at the logs at: %localappdata%/NVIDIA/CloudXR/logs

I misread and jumped the gun, sorry.
getting the logs for you now.
I will try adding a preconfigured device config, since according to the logs it’s working… even though it isn’t.
I’ll get the logs uploaded

Your image shows a plugin CloudXRRemoteHMD set to on which verifies CloudXR is installed and willing to accept client connections. I see nothing else to review. Can you submit any logs from the indicated directory?

Edit: I shutdown SteamVR before grabbing the logs.

According to the SteamVR status window, CloudXR isn’t running.
And it isn’t accepting client connections either.
Here’s the logs.

does it have to have a preinstalled device config to work?

Thanks for the log. I pinged one of our engineers for a sanity check but it looks like the server is up and waiting for a client to connect to it: Highlighted Waiting State on Server. It sat in this state for 44 minutes before it was closed. If a client was attempting to connect and seen by the server, the log includes “hole punching” steps that are missing. This means the server is up, but a client isn’t getting to it at all from the network to negotiate a connection.

Which device are you attempting to connect with?

Another test you can try is including a preconfigured config file on the server. This allows you to hard-set the view matrix, IPD, and other settings that are normally shared from the client to server upon connection negotiation. Note: this ignores any client HMD settings that would normally be passed, so delete this config if you’re using different HMDs or different IPD values

Based on your log (line #4), this goes in C:\Users\Shadow\AppData\Local\NVIDIA\CloudXR\CloudXRClientDescriptor.txt

I know VirtualDesktop conflicts with NVIDIA Cloud XR.
I made this ticket hoping I wouldn’t have to do a complete wipe for CloudXR TO WORK.
Gave up and did a complete wipe.

Okay, apparently it wasn’t a conflict.
Because it still won’t work.
Do I have to change something in the source code?
I thought it would work “out of the box” (after compiling).
The CXR icon(s) still isn’t showing up either.

Just installed Zerotier thinking thi issue could be caused by the connection issues making a proxy/vpn required just to connect to my cloud pc.
And that was indeed the cause of my issue.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.