Cloudxr server fails to find steamvr

The cloudxr setup of the server components complains that it cant find steamvr. Steam is installed on the system. Where is the setup script looking for steamvr. Also there doesnt actually seem to be a way to download and install steamvr from the steam sight. One can only launch it once steam is started. I tried to install cloudxr with a running instance of steamvr and it still failed. Any ideas?

One thing that may correct this is to make sure the CloudXR download and SteamVR are installed in the same user partition of the server. Occasionally, users will place SteamVR in an administrator account and CloudXR in a user account or vice versa and that could lead to this particular feedback.

1 Like

Hi there,

Assuming that we have the same issue, I was installing the server on a work laptop where the normal user account and the admin account were different users. I fixed it by doing the following:

  1. close all instances of steam. (make sure to exit)
  2. launch steam with admin credentials.
  3. login to steam.
  4. launch steamVR.
  5. close steam again. make sure to exit not just close.
  6. use cloudxr.exe installer.
  7. success!
  8. repeat 1-4 and you should see the remoteHMD in the steamVR addons too :)

Note if you do not launch steam without admin it will not see the remoteHMD option…

EDIT: I have found a fix to running it in admin please refer to here:
Issue with CloudXR SDK and SteamVR the fix by the nvidia employee made it possible to run without admin rights.