Issues trying to connect to CloudXR server 0x800831F4

Hi, new to CloudXR, I am blocked at the beginning without being able to connect to the server (steamVR is waiting for headset to be pluged-in and never see cloudxr icons on the server side (logs from 18.29.50). If I run TestServer.exe on the VM and then launch the client app I get a client disconnected (logs from 18.34.35)

My setup:
-connecting to a VM through VMWare Horizon Client, where I had steamVR and CloudXR Server successfully installed.
-using the client for windows with an htc vive.

I suspect I have network issues, I just do not realize what’s the real problem.
I checked version of client/server as suggested in thread: CloudXR - some computers give extended black screen?, but everything seems ok, running v3.1.1.1 on both sides
I also tried opening port 48010 (mentioned in log)

Any ideas on how to make it work?

CloudXR Client Log 2022-03-23 18.29.50.txt (1.8 KB)
Streamer Client Log 2022-03-23 18.29.50.txt (12.4 KB)
CloudXR Client Log 2022-03-23 18.34.35.txt (985 Bytes)
Streamer Client Log 2022-03-23 18.34.35.txt (13.6 KB)

Looks like firewall issues between your client and server?
“ConnectCommon failed, reason : Could not establish a connection to the server [cxrError_Could_Not_Connect_To_Server]”

In our lab-setup, previously experienced McAfee blocking ports when Windows Firewall was properly configured.

You may need to manually set up port forwarding/configuration for your VM. There’s more than one port involved.

Thanks for your answer, indeed, I agree I have something blocking connections, but I cannot find a detailed guide on ports and rules to add to make it work, any help there? Thanks.

Check the settings on the Windows Defender Firewall “Inbound Rules” (after CloudXR server is installed) should be the best reference.

CXR firewall

Which display protocol are you using with Horizon? I could not get it to work with Blast but it does work with PCoIP.