University permanent license issue

It comes out when I update the PGI from 15.7 to 16.1, and I have tried on both ubuntu 14.04 and CentOS 6.5 with my university permanent license.

run $lmutil diag

This license cannot be checked out because:
This platform not authorized by license.
Feature: PGI2016-######
Platforms: x64_lsb <> unidev, v16.1, nv, lin-acc
License path: /opt/pgi/license.dat:
FlexNet Licensing error:-89,310
For further information, refer to the FlexNet Licensing documentation,
available at “”.

I have searched the User Forum and tried many solutions, such as close the firewall, change the PORT and even re-installed my OS, besides, Dave from PGI also helps me a lot, but the problem is still unsolved.

I wonder if I was the only one who has met this problem?
Does anybody meet the same license issue?

The issue is that we changed how we handle the compilers with
Unidev Licenses after 15.7. The answer is to stop using 15.7 with the
current unidev license format. It does not work with 15.7.

We recommend 16.1 or 16.3 for Unidev License development.