USB Camera (C920)Detected via v4l-utils but not working to get streaming in Jetson Orin Nano

I have Jetson Orin Nano, when I have flash the image through SDK Manager, the camera was working fine with OpenCV and was able to see the real time streaming by passing the 0 index in video_cap = cv2.VideoCapture(0)
After a few days, now I am testing again but the camera is not working. I tried multiple solution from multiple resource but nothing works: the below command show me this information but nothing works when I am passing 0 or any index in opencv even tried “dev/video0”.

v4l2-ctl --list-devices
NVIDIA Tegra Video Input Device (platform:tegra-camrtc-ca):

HD Pro Webcam C920 (usb-3610000.xhci-2.4):

Further information of multiple commands are follow:

cat /etc/nv_tegra_release 
# R35 (release), REVISION: 4.1, GCID: 33958178, BOARD: t186ref, EABI: aarch64, DATE: Tue Aug  1 19:57:35 UTC 2023
dpkg-query --show nvidia-l4t-core
nvidia-l4t-core	35.4.1-20230801124926

These are also some information:

 v4l2-ctl --all -d /dev/video0
Driver Info:
	Driver name      : uvcvideo
	Card type        : HD Pro Webcam C920
	Bus info         : usb-3610000.xhci-2.4
	Driver version   : 5.10.120
	Capabilities     : 0x84a00001
		Video Capture
		Metadata Capture
		Extended Pix Format
		Device Capabilities
	Device Caps      : 0x04200001
		Video Capture
		Extended Pix Format
Media Driver Info:
	Driver name      : uvcvideo
	Model            : HD Pro Webcam C920
	Serial           : 05EBBDAF
	Bus info         : usb-3610000.xhci-2.4
	Media version    : 5.10.120
	Hardware revision: 0x00000011 (17)
	Driver version   : 5.10.120
Interface Info:
	ID               : 0x03000002
	Type             : V4L Video
Entity Info:
	ID               : 0x00000001 (1)
	Name             : HD Pro Webcam C920
	Function         : V4L2 I/O
	Flags         : default
	Pad 0x01000007   : 0: Sink
	  Link 0x0200001f: from remote pad 0x100000a of entity 'Processing 3': Data, Enabled, Immutable
Priority: 2
Video input : 0 (Camera 1: ok)
Format Video Capture:
	Width/Height      : 640/480
	Pixel Format      : 'YUYV' (YUYV 4:2:2)
	Field             : None
	Bytes per Line    : 1280
	Size Image        : 614400
	Colorspace        : sRGB
	Transfer Function : Rec. 709
	YCbCr/HSV Encoding: ITU-R 601
	Quantization      : Default (maps to Limited Range)
	Flags             :

Hi there @muhammad3 and welcome to the NVIDIA developer forums.

I think the dedicated Jetson category will give you better support for this topic. I hope you don’t mind my moving your post over there.


Hello @MarkusHoHo , thanks for your reply.
Sure, I will post there for better support , please share me the dedicated Jetson category for my issue. Thank you

Please refer to the steps in Jetson AGX Orin FAQ

Q: I have a USB camera. How can I launch it on AGX Orin?

If the issue persists, please consider re-flash the system and try again.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.