USB connectivity issues and packet loss on AGX Orinf with JP >= 5.1

We are stuck trying to resolve the USB connectivity & packet loss issues we are having.

The problem surprisingly seems to be with the Orin AGX Developer Kit as we have had no issues on Xavier’s both with AverMedia & SeedStudio boards that we tested with JP > 5.

The JP 5.1 test described below was run on 2 different AGX devices with the exact same results.

All our testing was done with the AGX plugged into wall power with only one device connected to a USB port for testing.

Here is a description of the issue from Addison our ROS2 expert:

We have a problem related to the USB ports on Jetson AGX Orin Developer Kit (Jetpack 5.1 and Jetpack 5.1.1). When we connect a USB device (e.g. RPLIDAR S2, the standard LIDAR that runs in NVIDIA’s own Isaac Nova Orin Robot Isaac Nova Orin Compute and Sensor Solution | NVIDIA Developer) to the Jetson, it works normally 5 out of 10 times. When it doesn’t work normally, either:

  1. The device does not start at all due to a connection timeout.
  2. The device starts but data is lost in the transmission (i.e. packet loss).
  3. The device starts and disconnects suddenly after 20-30 minutes.

We have tried the following approaches to try to solve the problem:

  1. Tested the exact same hardware and software on a Jetson Xavier running Jetpack 5.1.1. Everything worked perfectly.
  2. Power cycling the USB device did not work.
  3. Downloading the patch NVIDIA released that is supposed to fix the USB bug on Jetpack 5.1.1 did not work Jetson Linux 35.3.1 | NVIDIA Developer.
  4. Flashed Jetpack 5.1. That was even worse as we experienced total packet loss from the Lidar.
  5. Attempted to roll back to Jetpack 5.0.2 on the Orin…however, we had repeated failures trying to flash Jetpack 5.0.2 due to a particular “missing dtb file”.

The issue may be in power supply. Probably the device requires high current while running. Please connect the device to a USB hub with external power supply, and then connect to AGX Orin developer kit. See if it is more stable when supplying external power to the device.

Please also check Jetson/L4T -

[USB] nvidia-agx-orin-usb-connection-issues

And make sure the firmware version is 80.05 instead of 80.03.

Thanks DaneLLL,

Our tests were run with the AGX on wall power.
Lidar was also plugged in to wall power via a USB charger and its USB data cable was connected directly to the AGX.
So can we assume that it proves it is not a power issue?

Please share more detail about the setup. Looks like there’s one AGX Orin devkit with Jetpack 5.1.1. And it is connected to a device with Isaac SDK through USB. AGX Orin devkit is in USB host mode and the device with Isaac SDK is in device mode. Please help confirm the setup. And it would be great if you can share a picture of the setup.

80.05 is the latest USB firmware. If the issue is still present with the version, it is more like another issue.

Hi DaneLLL,

  1. We have an AGX Orin 64GB Devkit with Jetpack 5.1.1
  2. We have ROS2 Humble stack running in a uBuntu 22 Docker container. The container is running with privileged set to true.
  3. Are there additional flags I need to give to my container or config settings to give full access to USB?
  4. What is the command to check the USB firmware version?

Many thanks

Please check this print in dmesg:
Serial device hangs after closing, unable to re-open without first unplugging it - #9 by DaneLLL

Indeed we have 80.5
nvidia@orin2:~$ sudo dmesg | grep Firmware
[sudo] password for nvidia:
[ 7.850622] tegra-xusb 3610000.xhci: Firmware timestamp: 2023-02-10 03:48:10 UTC, Version: 80.05 release

However I also see many errors in the log:
[ 370.003415] tegra210-adsp tegra210-adsp: Broken Path2 - FE not linked to BE
[ 370.010590] tegra210-adsp tegra210-adsp: ASoC: error at snd_soc_component_open on tegra210-adsp: -32

Continuous output of lines similar to the above.
What do they mean?

The error is about audio. If you use Orin developer kit, it shouldn’t show the error. A bit strange it is printed.

Please share more information about the device. If there’s a Amazon link, please share us the link for reference.

FYI The AGX Orin 64GB showing the above error was simply connected to wall power & wifi with nothing else attached.

Will confirm the device specs from the supplier and update you.
However I think this is it (although we paid even more in Israel):

Sorry I didn’t describe it clearly. I mean the device in this comment:

When we connect a USB device (e.g. RPLIDAR S2, the standard LIDAR that runs in NVIDIA’s own Isaac Nova Orin Robot

Is there a Amazon link for the device?

Here is its manual

We have checked with our teams and confirmed we don’t use USB LIDARS in Isaac. So your set up should be Jetpack 5.1.1 and Isaac SDK is not in use. Please confirm this.

On AGX Orin developer kit, there are one USB hub with 4 type-A ports, two type-C ports(J39, J40). We would suggest try all the ports and check if the issue is specific to certain port(s).

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.