USB WiFi Dongle rtl8812au doesn't work on my Xavier


I saw this topic so I decided to try my COMFAST 1200Mbps USB Wireless Adapter(Model: CF-912AC) which is said to be compatible for the Jetson Nano on my Jetson AGX Xavier.

Before installing the driver

The usb dongle was not managed by the network manager.

After installing the drivers

I am able to see Wifi networks however I can’t connect to any of them. Whenever I try to connect to a network It acts as if the password entered was wrong. I tried several wifi networks and had the same results.

Do you know why it would work on Nano and not on Xavier ? Or if the problem is completely unrelated ?

Hi Everall,

We just merged some patches for RTL8812au. Please try to apply them. (2.75 KB) (305 Bytes) (7.35 MB)


Thank you for your answer, I tried on a computer running on ubuntu 18 and faced the same problem of authentication. The problem was the driver I installed and was solved by applying this patch .

I haven’t tried on the Xavier yet because I wanted to test what you suggested first but I am struggling to understand what I am supposed to do with these diff files. Could you explain me how and where I should apply them ?

The short answer is that if you unpack those, then the diff files show a difference between the default kernel source and the new kernel source. It is a list of files within the kernel source and the edits for making your source match the updates.

Those are human readable files, and basically line numbers and what to remove and then add within those lines for a match. You could refer to the listed files in the kernel source and read those with any text editor, and see how this provides changes to make. Then you’d need to read the docs on building and installing a kernel (the “kernel customization” section of the official docs).

The specific documents and kernel source downloads depend on which release you use, and I don’t know which release is involved. See:

JetPack is a front end to the command line flash software. If you examine this you’ll find the L4T version, and the L4T version in turn is from a specific JetPack version:

head -n 1 /etc/nv_tegra_release

JetPack tends to download many things for you, but the L4T page has specific documents and kernel source URLs. You might need to log in there and then go there a second time if redirect isn’t working.