USB WiFI Dongle running hot

Hello

I have had a jetson Nano for months now, that I have previously always powered through the micro USB port. Recently I switched to powering the rails, using a 6A 5V BEC for a drone. I ssh’ed into the Nano using a USB WiFI dongle that we have for Raspberry Pi applications, a MediaTek 802.11 n WLAN device.
I run fairly intensive ROS applications over a local network, with quite some traffic on the WiFi network. On my first nano, after a while I noticed no messages coming through anymore and the USB area feeling hot, so I unplugged it quickly, but since then the board cannot be powered (through any of the 3 options), and only the green power LED lights up. HDMI, serial, USB, Ethernet do not work anymore.
So I ordered another Nano (Rev3) (from CoreElectronics) and a 4A power supply (from Altronics).
After checking my other serial connection and making sure nothing was wrong there (with other devices and multimeter), I went ahead and tried running the experiments again. Suddenly I noticed a drop of messages again and a lack in connection and the USB WiFi dongle seemed to be almost hot to the touch, so I quickly unplugged everything again, to make sure nothing fries. I run the high-power nvpmode 0.
Does anyone have any idea what is going on, why this is suddenly getting hot and dropping out?

Any recommendations would be greatly appreciated, it is a kind of pressing matter due to a deadline coming up.

Kind regards
Nico

Hi, which port are you using? USB2.0 or USB3.0 port? It looks like something burnt as some power rail possibly shorted to ground. You can use multi-meter to check if any components shorted to ground.

Hello

I used the exposed USB 3 ports on the newer Rev 3. According to this document from sparkfun, p.3 the newer version only has USB 3. The Nano is not burnt and works, even with the same WiFi dongle (required for SSH access at this point), however, I cannot run my experiments out of fear it will overheat again.
For the old one that IS burnt: I cant tell which one is the USB 2 and which one the USB 3. How can I find out and which one should I plug the dongle in? I wanted to unscrew it from the carrier board and test to see if I could work it with another version or whether a short exists.

Kind regards
Nico

You can get the part number of connector by checking devkit user guide: https://developer.nvidia.com/embedded/dlc/Jetson_Nano_Developer_Kit_User_Guide

If it is extreme hot, there might be something shorted to ground, you can use multi-meter to check first.

The USB dongle was always connected to either J33 or J32, if that is what you are referring to. Is any of them preferred?
On the one that was fried I get a resistance of about 8 Ohm between pin 2 (5V) and pin 6 (GND) on the J41 Header. That does not seem right to me… Or is it that low?
6 (GND) to 8 (Tx) gave me about 6 MOhm.
2 (5V) to 39 (GND) about 0 Ohm (not a typo. 0)
The BEC that I used to power the rails was a 20A SBEC from YEP hooked up to a wall plug transformer over an xt60 header. The output cables have a ferrite ring for interference reduction. Any hints/clues?

Looking at the docs I found that the output current for the USB ports is limited to 1A. Could the higher power through the rails or the barrel connector be an issue there?
I have ordered an Edimax EW-7611ULB N150 Wi-Fi dongle, because Sparkfun used it in this tutorial and I might hope that to be more suitable. Or do I have to order the AC 8265 WiFi card, and if yes, is there a chance of frying that too? They have an order lead time of roughly 1 week in Australia, and I cannot afford wasting another week just by frying it.

Cheers for the help
Nico

The fried board seems that it is broken by shorting power rail to ground.
The load switch to vbus of J32 and J33 is TPS259530DSG, Ilim = 3A. We don’t have suggestion on device option. You can check datasheet of device to decide which one to choose.
Before that please make sure the devkit is normal, no components broken.

Well yes it seems to be fried. My question is: how does that happen when there is only power supplied through the rail and the only thing plugged in is a WiFi USB dongle??
Yeah the load limit of that device is 3A, however, the documentation you sent through (Section “Carrier Board”) states that each stack is limited to 1A max.

I checked under a magnifying glass and could not found any lose connections, cold solders or signs of frying.

Cheers
Nico

This may be a bit of a stab in the dark here, but how about this: I tried following this sparkfun tutorial and installed the drivers for the USB dongle. At first I had intermittently terrible pings (between 1ms and sometimes up to 3s), very similar to this issue reported here in this forum: #79530. So I ssh’ed back in via ethernet and disabled the powersaver mode, just like the sparkfun tutorial suggests. Running sudo iw dev wlan0 get power_saver after running set power_saver off apparently turns it back on.
After rerunning the set power_saver off and now pinging the Nano, I get pings ~1ms consistentyly. It’s been pinging for over a minute.
Quite a stab, but: could the overheating and the WiFi issue be unrelated?

Not sure why it is fried, it looks like USB dongle make it happen. You will see it is normal with other USB device. Before sw work on this, it should be guaranteed no such overheat problem. Better to check the datasheet of dongle or check with vendor for possible root cause.