Jetson Nano not responding or responding very slow over SSH.

I have been facing this weird problem for over three weeks and have tried a lot of different ways to tackle it but still can’t solve the problem.

The setup:

I am using the Jetson Nano for my drone so I have connected my Pixhawk FCU to the Nano via USB.
I have also connected a ZED Mini camera using USB.
I have powered the Nano using a 4-cell LiPo battery via the barrel jack. There is a Power Distribution Board in between to make sure constant 5V is supplied to the Nano.
I had initially connected a WiFi dongle to the Nano, but later on, switched to the Intel WiFi adapter.

The problem:

I SSH to the Nano via my laptop and run MAVROS (ROS) node and the ZED ROS wrapper. I also run my own node which is a simple PID controller. But as soon as I start the ZED wrapper, the SSH connection becomes very slow or just stops responding. I start pinging the Nano from another terminal and see that there is no ping response or it says “Destination Host Unreachable”. I also have monitored the system’s memory usage via ‘htop’ and it doesn’t use any more than 50% on all the cores.
But interestingly, if I have connected the Nano to a display via HDMI, the system is working fine on that end. I can operate from there. I tried changing the power supply to an adapter, changed the WiFi dongle, changed the SD card, turned off the network power saver, added a fan on the heatsink, but the problem still persists.

The problem also isn’t consistent, I can test my stuff on a few lucky days with absolutely no lag, but a lot of times I face this problem and can’t find a fix to it. I know the description seems a little weird but if you need any more logs then please tell me but I desparately need to fix this issue.

Thank you for your time.

1 Like

Curious if the Rpi solutions would fix your issues.

Check out the UseDNS item mentioned in this link. I’m curious if that will help.https://www.raspberrypi.org/forums/viewtopic.php?t=157517

This problem sounds have many variables here. Wifi adapter/ROS node/ZED wrapper and HDMI (also, issue is intermittent).

Could you try to narrow down the minimum requirement for reproduce this issue? Actually, I don’t know what is ZED ROS wrapper. Could you share the detail too?

This is a common issue with Jetsons, the wifi has a power saving mode you can change with this command:

$ iw dev wlan0 set power_save off

you can restore this by

$ iw dev wlan0 get power_save
4 Likes

This has helped me a lot. I had reported an issue (#126346) that I noticed the connection dropping out when I ran experiments over WiFi. Upon touching the nano ran extremely hot, so I suspected an overheating issue.
state today (08/06/2020 - that’s EU format, not american), turning off the power saver mode at least keeps the pings at a constant pace (~1ms) so it apparently helps with that. I will run my ROS experiments and report if they have been affected by the connection.
Thanks for the hint behnam!

When I run the command, I am getting the error command failed: Operation not permitted (-1)

When I run sudo iw dev wlan0 set power_save off , I get the error command failed: No such device (-19)

Any idea how to solve this? wlan0 is present, and active connnection.

Output of the iwconfig command:

usb0      no wireless extensions.

lo        no wireless extensions.

dummy0    no wireless extensions.

eth0      no wireless extensions.

rndis0    no wireless extensions.

l4tbr0    no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"TP-Link_8749"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:2.452 GHz  Access Point: 28:EE:52:B8:87:49   
          Bit Rate:72.2 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=100/100  Signal level=100/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0