USD Composer 2023.2.0

Hi there…
I’ve tried installing several times: Hung up on: Installing Pull_Kit_SDK.Bat Then I received an error message:

Error occurred during installation of USD Composer: 2023-11-07 17:29:15 [529,453ms] [Error] [omni.ext.plugin] Failed to pull extension: ‘omni.flowusd-105.1.44’ in ‘c:/users/michael/appdata/local/ov/pkg/deps/b97758a1d94107ddc7e7f3c762d1c90e/extscache’.
[omni.kit.registry.nucleus] [tid: 23052] creating a link: c:/users/michael/appdata/local/ov/pkg/deps/b97758a1d94107ddc7e7f3c762d1c90e/extscache/ →

Would love your guidance on this. Thanks so much!

@rizzimeta i am just another user, but one of the reasons why it could happen is if you have antivirus/windows security active or don’t have proper port open. perhaps if you can upload your Launcher log, there might be relevant information that could help others/mods/devs troubleshoot your install issue.

you can find the log here - C:\Users\michael\.nvidia-omniverse\logs\launcher.log

@Simplychenable, Thanks so much for the suggestion and your help!
Please see attached log and thanks again!
launcher.log (4.7 MB)

based on the log, it seems like there are more than one extension having the same pull error. if you dont mind me asking whether you machine is personal or part of an org? if it’s part of an office equipment, did someone from IT set up OV? did you already attempt installing other Composer versions (or other OV apps) in order to confirm whether the same problem persist during installation?

regarding your setup, i noticed in the log provided that you may not have cache installed, is that correct? what about nucleaus services and a nucleus server (most common on a machine is a localhost)?

Thanks again for this. The machine is a personal one with; Cache (2023.1.0) and USD Composer (2022.3.3) installed. As I think about the port, I am wondering if I should have enabled sharing on a public network during the initial set up. Not sure if that would have anything to do with my issue. I restored default settings for omniverse ports. In addition, Microsoft Defender Firewall is on for public, domain and private. Thank so much for your help!

Your log is very unusual. You have a massive amount of errors all relating to connection issues. I would certainly suggest you do a complete reboot of your machine, then check for a strong internet connection, then make sure your firewall is off temporarily and that you can get out to all the required omniverse installation paths.

Please try again and let me know.

@Richard3D That worked! Two reboots and disabling firewall (temporarily) did the trick. The install still got hung up a bit, but I finally received a pop up asking if I wanted to install and that was it! My thanks to you and @Simplychenable


Great thanks !

I also have the problem of not being able to install version 2023.2.0 and seen that it can possibly help pausing the firewall etc. I’m with a big company with all kinds of security to stop hackers etc., and all this makes installing USD Composer a challenge.

I am a bit confused though about this version 2023.2.0 because it’s listed as a Beta version. With a clean Omniverse launcher, when you select to install the USD Composer, both under “Release” and “Enterprise” only version 2022.3.3 is available.
What is the difference between the two, and are the problems in installing 2023.2.0 caused by it being a beta version?
When you have 2022.3.3 installed, you are invited to update to 2023.2.0 by a small green bell, and it doesn’t say it’s a beta.

What is the best thing to do, wait until 2023.2.0 is no longer beta or?

/Thomas, Copenhagen

1 Like

Thanks for the post. Yes I admit the beta tag seems confusing but it is the latest and greatest version and you should certainly try to use it.

As far as installing, the new version requires a two part installation unlike the old version. The new requires a small 88mb download and then a much larger “pull down” of extensions. It’s the second part that can cause problems with company firewalls because it has to go out live to several “off grid” extension registries.

So you need to talk to your IT about temp allowing your workstation to get out to the internet uninhibited.

1 Like

We switch between releasing a beta and a GA / Release. Usually twice a year. Our next release should be early next year as a GA. 2023.2.1

1 Like

You will need to open your firewall to at least these web links

If you are an Enterprise customer we do offer an “air-gapped” version of the installer which installs “offline” as a single zip file. You would have to contact your Enterprise Rep for that.

1 Like

Thanks Richard, certainly valuable info for our IT dept. We will follow your suggestions :-)
I’ll report back soon …


1 Like

Great thanks !

Still cannot install the 2023.2.0 Beta version despite turning off all Windows Firewalls…

@karol.osinski are you getting any Launcher error messages or is it getting stuck at Installing Pull_Kit_SDK.Bat?

Yes, same story here in my company. We are rather stuck at the moment, turning of everything we can doesn’t help.
Too bad the offline installation file is only for Enterprise customers. Without being able to install on our system, and test Omniverse, we will not dare considering being Enterprise customers.

@thnhome do you know if your IT already reviewed the TCP/IP information on this page?

both the ports and the outbound connectivity requirements at the bottom of the page are both relevant for configuration. if you and your company already have gone through this information, feel free to ignore.

Anyone having installation issues, please send it your logs at C:\Users\USER\nvidia-omniverse\logs

1 Like

Hi Richard, thank you

btw for now I installed 2023.1.1 on my machine, however I managed to install 2023.2.0 on my collegue’s machine without issues.

launcher.log (855.9 KB)