Connection issue from Launcher Apps to Nucleus Server

Hey folks,

i’m facing a strange connection issue on my Nucleus server. While the connection from the web fronted is working fine from my testmachine, and also the local Nucleus server instance can be establish a connection to the central Nucleus server i’m unable to get a connection for my Launcher Apps (like USD Presenter or USD Composer). It just tries to connect “Connection requires a login authentication. Please login from web browser.” But no browser popup for authentication appears, it just gives me an error message “Unable to connect server. Please check your internet connection”. As it works for the local Nucleus and the web frontend I guess the issue is not the connectivity at all, it’s more that the popup does not appear for logging in.

Anyone else is facing or faced an issue like this and have a solution for it?

The most likely thing is that your local and Nucleus bookmarks in the apps have “gone stale”. I would delete all the shortcuts from file browsers in the apps and remake them fresh.

First, you want to make sure you are fully authorized in the Launcher. I would log out and then log in. Refresh it. Then do the same for Nucleus inside of Launcher. Start by deleting old shortcuts and servers and make them fresh. Then start your apps and make a new fresh connection to localhost and your Nucleus servers. It should not ask you twice if you have just done this in the Launcher version of Nucleus.

I just started up composer for the first time, and I get the same error message. Is there anything else that could be going on?

What is are you attempting to run composer on? Does your machine have access to the nucleus server you’re attempting to connect to?
Can we see verbose logs from composer please?

I am able to browse the Nucleus server in the launcher, however when I open a USD fiile in composer, the file is not opened. The server is in the content tab, but there is nothing inside. After a while a tab shows up with the error message from before.

Log File:

kit_20240520_141700.log (1.1 MB)

Ok so it sounds like a stale link. Just delete the server from USD Composer and quit it. Then delete it from Nucleus as well. Re-initialize it in Nucleus with a fresh log in and authentication. Then start USD Composer again and it should be there automatically and working. If not, add the server again manually.

I have done everything here and it still doesn’t work

Are you trying to get here: ?
server omniverse:// ConnectionStatus.SIGNED_OUT

It is saying you are signed out. Please simply make sure you are fully logged into your Launcher account and then fully logged into this nucleus server. If you are not getting a popup then you have stale browser cookies. You need to be using a CHROMIUM browser like Edge or chrome. You can wipe your cookies and browsing data to force it to show up. It could be that this server is down. Talk to your IT dept.

I am logged into the launcher. I removed the server from the nucleus tab, and reconnected. I can browse the server files from the launcher. Now if I go to a USD file and try to open it in USD Composer or any other app, Composer will open but nothing will be there. I can see the server in the content browser, but nothing is in there. If I right click on it and try to reconnect, It will tell me I need to sign in from the browser. No browser pops up, and there is no way to force the browser to pop up. I tried clearing my browsing data as suggested, and chrome is set as my default browser. I finally checked with the System Admin and he assures me that the server is up and running. My coworkers are also able to access the server.

Can you please send us the verbose logs from the app you are running?

Also, what os and machine spec are you running on?

Can you send me a video of you trying to open a file. I am not clear if you are trying to open the file in Launcher and specifying USD Composer as the “open” app, or if you are starting USD Composer first and trying to browse the server, then open. Maybe both. Please send us a video showing the exact issue.

Just as a tip you can find the file in Nucleus Launcher and double click it and it will ask you what app to open in, and you can specify USD Composer. Then it should transfer the file directly to USD Composer. Try that as well.

Ok so lets try this. Go to Preferences > Reset to Default and let it totally restart with fresh settings.

Then show me a video of you deleting that server and adding it back in, inside in Composer. We want to see that POPUP come up for a login. If you do not get it, we have to focus on that.

I did reset to default prior to this video.

Is this a local workstation, or a VM?

Do you have a default web browser set in your windows system?

This is a workstation. The default browser is set to chrome

please open a cmd.exe and run
start I’m assuming that is the correct URL (please validate)

This is what the Kit app is calling when attempting to connect to the server. This command should popup a web browser taking you to the web version of Navigator.

If that works, please restart your computer, and try the Kit app again.

If that doesn’t work, you’ll need to look at your machine, and make sure there’s not some hidden chrome browser, or something else may be wrong unfortunately.

that is the correct URL. I opened cmd and ran the line. It took me to a browser window where I signed in and I was taken to the web navigator. I restarted, but there is no change.

Can you try uninstalling and reinstalling the Kit app. It seems something on your machine is having an issue with connecting to the standard call.

I would still request your verbose kit logs to be able to determine the issue.

You should also validate with your Nucleus admin that the certs are up to date and valid.

If that does not work we may have to go with a full Omniverse Wipe and reinstall.