The Nucleus service appears to be unresponsive

Hello,

after opening Omniverse Launcher I keep getting this error message:

I am using Ubuntu 20.04.3 and a local Nucleus Server 2021 3.2.
It was working yesterday without a problem. Today I updated Isaac Sim to version 2.1 and it stopped working (I’m not sure if it’s related).

If I go to localhost:3080 I get the error “Cannot connect to System Monitor Backend”

I tried uninstalling and installing nucleus again but it did not help. Here are my logs from /.nvidia-omniverse/logs and /.nvidia-omniverse/logs/Nucleus:

logs.zip (494.7 KB)

Can you help me solve this issue? And in the meantime, is there a quick way to recover the Projects that I had stored in my Nucleus /Projects folder?

Hi @jominga , and thank you for joining the community forum! I see a similar thread on this error here: Cannot connect to System Monitor Backend - #18 by dduka

Can you try some of the suggestions outlined in the thread…if that does not help, we’ll probably need to look at your files, but let me know.

Regarding recovering project files, are you using Drive (Drive Connect — Omniverse Utilities documentation)?

Cheers,
Edmar

P.S. We are constantly adding new tutorials and aggregate them all in the “learn” tab on the launcher (also see: NVIDIA Omniverse Tutorials | NVIDIA Developer).

he / him | LinkedIn | Discord ID: Prof E#2041
Omniverse: “A New Era of Collaboration and Simulation” (video)
Omniverse Create’s latest features show & tell: Twitch livestream.
As seen in VentureBeat | Physics Showcase

Omniverse Resources:
Open Beta | Documentation | Tech Requirements | Videos | Roadmap | Twitter | Discord | Twitch

PLEASE NOTE: If you are reporting a bug/issue, please provide OS, GPU, GPU Driver, the version of the app, and full log file (if applicable). For crashes, please zip and provide a link to your logs → C:\Users\ [YOUR NAME] \ .nvidia-omniverse\logs

Hello @emendizabal, thanks for your response.

I came across that thread before posting my message but the suggestions there did not help (I could not find any ports.toml file in my omniverse folder).

I am using Ubuntu, so Drive is not an option for now, since it is only compatible with Windows.

Let me know exactly what files other than the ones I already posted could help figure out what’s wrong and I’ll upload them.

Thanks in advance!

Hello @jominga. I passed along your log files to the development team to get some feedback from them.

Meanwhile, I took peek at your log files and found 2 errors that stood out to me:

Failed to lstat the base path “/home/USERNAME/.local/share/ov/pkg/nucleus-workstation-2021.3.2” for component nucleus-workstation@2021.3.2 Error: ENOENT: no such file or directory, lstat ‘/home/USERNAME/.local/share/ov/pkg/nucleus-workstation-2021.3.2’

(node:22165) electron: The default of contextIsolation is deprecated and will be changing from false to true in a future release of Electron. See [Discussion] Changing the defaults for nodeIntegration and contextIsolation to improve the default security posture of Electron applications · Issue #23506 · electron/electron · GitHub for more information

Here are a couple of things you can try that have worked for other users. Let me know if you have already tried them.

Do you have a default Browser (like Chrome) set on your computer? If not, set one up so that Nucleus has a way to access the internet, then try to log in again.

  1. Uninstall Cache
  2. Download Nucleus from NVIDIA Isaac Sim - Getting Started | NVIDIA Developer
  3. Try to install Nucleus on Omniverse launcher then it’s download setup folder in “~/.local/share/ov/pkg/nucleus-workstation-2021.2.4/”
  4. Extract and paste on “~/.local/share/ov/pkg/nucleus-workstation-2021.2.4/” the downloaded nucleus zip (step 2) file except setup folder.
  5. And try to install nucleus again.
  6. Reinstall Cache.

Also, please take a look at our Linux Troubleshooting doc here: Linux Troubleshooting — Omniverse Nucleus documentation

1 Like

Hallo WendyGram,

I ended up reinstalling all Omniverse from scratch and now it works.

Thank you!