Nucleus Workstation error and stopped working

Hi, I run headless Isaac Sim to access the assets from localhost, however it always get authentication error.
and then I open the nucleus, and it get error and stopped working everytime I run it.
I tried to cleanup the omniverse launcher installation but the error still happens.

I attached the log in here. I will be grateful for any help. Thank you.
Nucleus.log (369.7 KB)

Update: when I tried to access files inside nucleus using headless isaac sim, this warning happened and the files cannot be accessed at all.

I make sure everything was connected beforehand.

Hi, You can get help for Nucleus in the Omniverse Forums.

Try uninstalling Nucleus. You should still be able to run the Isaac Sim examples by pulling the assets automatically from the Cloud.

I already uninstalling and installing Nucleus, uninstalling and installing again Omniverse Launcher, Isaac Sim, and nucleus. download the Isaac folder and mount it inside library folder within the Nucleus, even turn off firewall, turning off the cache, deleting the cache folder, and I still cannot pull the Isaac Sim examples assets using Isaac Sim headless mode.

Have you tried running Isaac Sim with Cache and Nucleus uninstalled? Please share the Isaac Sim logs with this setup.

Hi Sheikh,
I uploaded the Isaac Sim log with Cache and Nucleus uninstalled:
kit_20221209_163908.log (1.1 MB)

And the other one only for Nucleus installed and Cache uninstalled. In this state, I can access the usd file that i uploaded by myself but not the NVIDIA files in headless mode. I can access both in normal mode.
kit_20221206_135325.log (2.0 MB)

Hi. Good to hear that it works in normal mode.
How do you run Isaac Sim in headless? Through the terminal or App Selector?
What is your run command if you run from the terminal.

While running Isaac Sim headless and livestreaming into the app, can you click on “Nucleus Check” in the “Isaac Utils” Menu?. This check will show you which path the assets is reading from.

Hi Sheikh,

I didn’t manage to click on “Nucleus Check” in the “Isaac Utils” menu.
I run the headless Isaac Sim through the terminal, and will post the log here.

<mycomputer>:~/projects/$ ~/.local/share/ov/pkg/isaac_sim-2022.1.1/./ --/renderer/multiGpu/enabled=false --config_file="hospital.yaml"
Starting kit application with the fillowing args:  ['/home/aic/.local/share/ov/pkg/isaac_sim-2022.1.1/exts/omni.isaac.kit/omni/isaac/kit/', '/home/aic/.local/share/ov/pkg/isaac_sim-2022.1.1/apps/omni.isaac.sim.python.kit', '--/app/tokens/exe-path=/home/aic/.local/share/ov/pkg/isaac_sim-2022.1.1/kit', '--/persistent/app/viewport/displayOptions=3094', '--/rtx/materialDb/syncLoads=True', '--/rtx/hydra/materialSyncLoads=True--/omni.kit.plugin/syncUsdLoads=True', '--/app/renderer/resolution/width=1920', '--/app/renderer/resolution/height=1080', '--/app/window/width=1440', '--/app/window/height=900', '--/renderer/multiGpu/enabled=True', '--ext-folder', '/home/aic/.local/share/ov/pkg/isaac_sim-2022.1.1/exts', '--ext-folder', '/home/aic/.local/share/ov/pkg/isaac_sim-2022.1.1/apps', '--/physics/cudaDevice=0', '--portable']
Passing the following args to the base kit application:  ['--/renderer/multiGpu/enabled=false', '--config_file=hospital.yaml']
[Warning] [] No crash reporter present, dumps uploading isn't available.
[Info] [carb] Logging to file: /home/aic/.local/share/ov/pkg/isaac_sim-2022.1.1/kit/logs/Kit/Isaac-Sim/2022.1/kit_20221212_093218.log
2022-12-12 01:32:18 [5ms] [Warning] [omni.ext.plugin] [ext: omni.drivesim.sensors.nv.lidar] Extensions config 'extension.toml' doesn't exist '/home/aic/.local/share/ov/pkg/isaac_sim-2022.1.1/exts/omni.drivesim.sensors.nv.lidar' or '/home/aic/.local/share/ov/pkg/isaac_sim-2022.1.1/exts/omni.drivesim.sensors.nv.lidar/config'
[0.116s] [ext: omni.stats-0.0.0] startup
[0.148s] [ext: omni.gpu_foundation-0.0.0] startup
2022-12-12 01:32:18 [161ms] [Warning] [carb] FrameworkImpl::setDefaultPlugin(client: omni.gpu_foundation_factory.plugin, desc : [carb::graphics::Graphics v2.5], plugin : failed. Plugin selection is locked, because the interface was previously acquired by: 
[0.180s] [ext: carb.windowing.plugins-1.0.0] startup
[0.195s] [ext: omni.assets.plugins-0.0.0] startup
[0.200s] [ext: omni.kit.renderer.init-0.0.0] startup
MESA-INTEL: warning: Performance support disabled, consider sysctl dev.i915.perf_stream_paranoid=0

| Driver Version: 520.61.5      | Graphics API: Vulkan
| GPU | Name                             | Active | LDA | GPU Memory | Vendor-ID | LUID       |
|     |                                  |        |     |            | Device-ID | UUID       |
| 0   | NVIDIA GeForce RTX 3070 Laptop.. | Yes: 0 |     | 8192    MB | 10de      | 0          |
|     |                                  |        |     |            | 249d      | 665710bc.. |
| 1   | Intel(R) UHD Graphics (TGL GT1)  |        |     | 23899   MB | 8086      | 0          |
|     |                                  |        |     |            | 9a60      | ee98bced.. |
| OS: Linux riska-predator-ph317-55, Version: 5.15.0-56-generic
| XServer Vendor: The X.Org Foundation, XServer Version: 12013000 (
| Processor: 11th Gen Intel(R) Core(TM) i7-11800H @ 2.30GHz | Cores: Unknown | Logical: 16
| Total Memory (MB): 31865 | Free Memory: 26251
| Total Page/Swap (MB): 2047 | Free Page/Swap: 2047
2022-12-12 01:32:19 [918ms] [Warning] [] Disabling OpenGL Interop. Device 0 mismatched with OpenGL device: Mesa Intel(R) UHD Graphics (TGL GT1).
OpenGL can only run on the main GPU. It requires the app to run with activeDevice setting set to that GPU. On laptops, you may also need to specify which GPU or driver to run on in your system (Integrated or Discrete).
2022-12-12 01:32:19 [918ms] [Warning] [] Realm: no OpenGL interop context.
2022-12-12 01:32:19 [976ms] [Warning] [carb.cudainterop.plugin] On Linux only, CUDA and the display driver does not support IOMMU-enabled bare-metal PCIe peer to peer memory copy.
However, CUDA and the display driver does support IOMMU via VM pass through. As a consequence, users on Linux,
when running on a native bare metal system, should disable the IOMMU. The IOMMU should be enabled and the VFIO driver
be used as a PCIe pass through for virtual machines.
[1.000s] [ext: omni.kit.pipapi-0.0.0] startup
[1.015s] [ext: omni.kit.pip_archive-0.0.0] startup
[1.019s] [ext: omni.isaac.core_archive-1.2.0] startup
[1.048s] [ext: omni.usd.config-1.0.0] startup
[1.050s] [ext: omni.usd.libs-1.0.0] startup
[1.349s] [ext: omni.kit.pip_torch-1_11_0-0.1.3] startup
[1.397s] [ext: omni.isaac.ml_archive-1.1.0] startup
[1.466s] [ext: omni.kit.loop-isaac-0.1.0] startup
[1.468s] [ext: omni.kit.async_engine-0.0.0] startup
[1.469s] [ext: omni.appwindow-1.0.0] startup
[1.475s] [ext: omni.client-0.1.0] startup
[1.508s] [ext: omni.kit.test-0.0.0] startup
[1.509s] [ext: omni.kit.renderer.core-0.0.0] startup
[1.622s] [ext: omni.ui-2.10.3] startup
[1.652s] [ext:] startup
[1.676s] [ext: omni.kit.mainwindow-0.0.0] startup
[1.680s] [ext: omni.uiaudio-1.0.0] startup
[1.683s] [ext: omni.kit.uiapp-0.0.0] startup
[1.683s] [ext: omni.usd.schema.physics-1.0.0] startup
[1.746s] [ext:] startup
[1.754s] [ext: omni.usd.schema.semantics-0.0.0] startup
[1.768s] [ext: omni.usd.schema.omnigraph-1.0.0] startup
[1.778s] [ext: omni.usd.schema.anim-0.0.0] startup
[1.824s] [ext: omni.kit.commands-1.2.2] startup
[1.830s] [ext: omni.timeline-1.0.2] startup
[1.833s] [ext: omni.hydra.scene_delegate-0.2.0] startup
[1.846s] [ext: omni.kit.audiodeviceenum-1.0.0] startup
[1.848s] [ext: omni.usd-1.5.3] startup
[1.925s] [ext: omni.kit.asset_converter-1.2.31] startup
[1.976s] [ext: omni.usd.schema.physx-0.0.0] startup
[2.010s] [ext: omni.usd.schema.isaac-0.2.0] startup
[2.060s] [ext: omni.usd.schema.forcefield-0.0.0] startup
[2.069s] [ext: omni.kvdb-0.0.0] startup
[2.073s] [ext: omni.usdphysics-1.4.15] startup
[2.076s] [ext:] startup
[2.105s] [ext: omni.localcache-0.0.0] startup
[2.109s] [ext: omni.kit.stage_templates-1.1.2] startup
[2.111s] [ext: omni.convexdecomposition-1.4.15] startup
[2.115s] [ext: omni.physics.tensors-0.1.0] startup
[2.124s] [ext: omni.physx-1.4.15-5.1] startup
[2.163s] [ext: omni.graph.core-2.29.1] startup
[2.176s] [ext:] startup
[2.190s] [ext: omni.physx.tensors-0.1.0] startup
[2.199s] [ext: omni.graph-1.23.0] startup
[2.275s] [ext: omni.kit.numpy.common-0.1.0] startup
[2.279s] [ext: omni.kit.window.script_editor-1.6.2] startup
[2.294s] [ext: omni.kit.search_core-1.0.2] startup
[2.296s] [ext: omni.isaac.dynamic_control-1.1.0] startup
[2.313s] [ext: omni.kit.renderer.capture-0.0.0] startup
[2.318s] [ext: omni.kit.widget.filebrowser-2.2.27] startup
[2.328s] [ext: omni.kit.widget.path_field-2.0.3] startup
[2.330s] [ext: omni.kit.notification_manager-1.0.5] startup
[2.336s] [ext: omni.kit.widget.versioning-1.3.8] startup
[2.339s] [ext: omni.kit.widget.browser_bar-2.0.3] startup
[2.341s] [ext: omni.kit.window.popup_dialog-2.0.8] startup
[2.343s] [ext: omni.mdl.neuraylib-0.1.0] startup
[2.348s] [ext: omni.kit.window.filepicker-2.4.30] startup
[2.404s] [ext:] startup
[2.405s] [ext: omni.mdl-0.1.0] startup
[2.429s] [ext: omni.kit.window.file_importer-1.0.4] startup
[2.430s] [ext: omni.kit.window.file_exporter-1.0.4] startup
[2.431s] [ext: omni.kit.material.library-1.3.10] startup
[2.434s] [ext: omni.kit.window.drop_support-1.0.0] startup
[2.435s] [ext: omni.kit.window.file-1.3.16] startup
[2.438s] [ext: omni.kit.context_menu-1.3.9] startup
[2.442s] [ext:] startup
[2.444s] [ext: omni.kit.window.content_browser-2.4.28] startup
[2.460s] [ext: omni.kit.widget.stage-2.6.15] startup
[2.465s] [ext: omni.isaac.version-1.0.0] startup
[2.466s] [ext:] startup
[2.495s] [ext: omni.kit.viewport.legacy_gizmos-1.0.0] startup
[2.498s] [ext: omni.hydra.rtx-0.1.0] startup
[2.529s] [ext: omni.renderer-rtx-0.0.0] startup
[2.533s] [ext: omni.hydra.engine.stats-1.0.0] startup
[2.538s] [ext: omni.debugdraw-0.1.0] startup
[2.543s] [ext: omni.kit.widget.settings-1.0.0] startup
[2.545s] [ext: omni.kit.window.viewport-0.0.0] startup
[3.446s] [ext: omni.kit.widget.prompt-1.0.1] startup
[3.447s] [ext: omni.kit.widget.graph-1.4.3] startup
[3.455s] [ext: omni.kit.window.preferences-1.2.1] startup
[3.483s] [ext: omni.ui_query-1.1.1] startup
[3.485s] [ext: omni.graph.ui-1.6.1] startup
[3.542s] [ext: omni.kit.ui_test-1.2.2] startup
[3.545s] [ext: omni.graph.action-1.18.0] startup
[3.558s] [ext: omni.kit.widget.searchfield-1.0.6] startup
[3.560s] [ext: omni.kit.usd_undo-0.1.0] startup
[3.561s] [ext: omni.graph.scriptnode-0.5.0] startup
[3.564s] [ext: omni.physx.commands-1.4.15-5.1] startup
[3.569s] [ext: omni.graph.nodes-1.26.0] startup
[3.591s] [ext: omni.command.usd-1.0.1] startup
[3.595s] [ext: omni.kit.window.extensions-1.1.0] startup
[3.600s] [ext: omni.syntheticdata-0.2.1] startup
[3.648s] [ext: omni.kit.primitive.mesh-1.0.0] startup
[3.653s] [ext: omni.warp-0.2.2] startup
Warp initialized:
   Version: 0.2.2
   CUDA device: NVIDIA GeForce RTX 3070 Laptop GPU
   Kernel cache: /home/aic/.cache/warp/0.2.2
[4.755s] [ext: omni.isaac.ui-0.2.1] startup
[4.758s] [ext: omni.replicator.core-1.4.3] startup
[4.933s] [ext: omni.isaac.core-1.24.3] startup
[5.024s] [ext: omni.physx.ui-1.4.15-5.1] startup
[5.083s] [ext:] startup
[5.086s] [ext: omni.kit.window.toolbar-1.2.4] startup
[5.092s] [ext: omni.isaac.core_nodes-0.13.0] startup
[5.161s] [ext: omni.physx.demos-1.4.15-5.1] startup
[5.164s] [ext:] startup
2022-12-12 01:32:23 [5,201ms] [Warning] [omni.physx.plugin] Deprecated: getSimulationEventStream is deprecated, please use getSimulationEventStreamV2
[5.219s] [ext: omni.physx.tests-1.4.15-5.1] startup
[5.359s] [ext: omni.isaac.wheeled_robots-0.5.8] startup
[5.372s] [ext:] startup
[5.374s] [ext: omni.physx.vehicle-1.4.15-5.1] startup
[5.388s] [ext: omni.physx.cct-1.4.15-5.1] startup
[5.435s] [ext:] startup
[5.443s] [ext: omni.kit.widget.stage_icons-1.0.2] startup
[5.445s] [ext: omni.ui.scene-1.5.0] startup
[5.455s] [ext: omni.physx.bundle-1.4.15-5.1] startup
[5.455s] [ext: omni.kit.window.stage-2.3.7] startup
[5.459s] [ext: omni.replicator.composer-1.1.3] startup
[5.462s] [ext: omni.isaac.lula-1.1.0] startup
[5.482s] [ext: omni.rtx.window.settings-0.6.1] startup
[5.488s] [ext: omni.isaac.surface_gripper-0.1.2] startup
[5.494s] [ext: omni.isaac.motion_planning-0.2.0] startup
[5.505s] [ext: omni.rtx.settings.core-0.5.5] startup
[5.510s] [ext: omni.isaac.manipulators-1.0.1] startup
[5.513s] [ext: omni.isaac.motion_generation-3.6.1] startup
[5.519s] [ext: omni.kit.widget.zoombar-1.0.3] startup
[5.520s] [ext: omni.kit.graph.delegate.default-1.0.15] startup
[5.523s] [ext: omni.isaac.franka-0.3.0] startup
[5.524s] [ext: omni.kit.browser.core-2.0.12] startup
[5.529s] [ext: omni.kit.graph.editor.core-1.3.3] startup
[5.532s] [ext: omni.kit.graph.usd.commands-1.1.0] startup
[5.534s] [ext: omni.kit.browser.folder.core-1.1.13] startup
[5.537s] [ext: omni.kit.graph.widget.variables-2.0.2] startup
[5.538s] [ext: omni.kit.graph.delegate.modern-1.6.0] startup
[5.540s] [ext: omni.kit.selection-0.1.0] startup
[5.541s] [ext: omni.isaac.debug_draw-0.1.2] startup
[5.548s] [ext: omni.graph.window.core-1.23.4] startup
[5.555s] [ext: omni.graph.instancing-1.1.4] startup
[5.561s] [ext:] startup
[5.563s] [ext: omni.isaac.isaac_sensor-1.0.2] startup
2022-12-12 01:32:23 [5,559ms] [Warning] [omni.physx.plugin] Deprecated: getSimulationEventStream is deprecated, please use getSimulationEventStreamV2
[5.579s] [ext: omni.graph.tutorials-1.1.2] startup
[5.598s] [ext: omni.graph.window.action-1.3.8] startup
[5.600s] [ext:] startup
2022-12-12 01:32:23 [5,588ms] [Warning] [omni.ext-live.plugin] Unable to detect Omniverse Cache Server. File /home/aic/.nvidia-omniverse/config/Cache/Omniverse.toml is not found. Consider installing it (version >= 280) for better IO performance.
[5.605s] [ext: omni.kit.widget.layers-1.5.17] startup
[5.620s] [ext: omni.graph.bundle.action-1.0.0] startup
[5.620s] [ext: omni.isaac.range_sensor-0.4.3] startup
[5.644s] [ext:] startup
[5.646s] [ext: omni.replicator.isaac-1.3.2] startup
[5.753s] [ext: omni.isaac.kit-0.2.1] startup
[5.753s] [ext: omni.graph.window.generic-1.3.8] startup
[5.755s] [ext: omni.isaac.utils-0.1.11] startup
[5.759s] [ext:] startup
[5.761s] [ext:] startup
[5.763s] [ext:] startup
[5.764s] [ext:] startup
[5.766s] [ext:] startup
[5.768s] [ext:] startup
[5.769s] [ext:] startup
[5.773s] [ext: omni.isaac.universal_robots-0.3.0] startup
[5.774s] [ext: omni.isaac.occupancy_map-0.2.4] startup
[5.787s] [ext: omni.kit.window.console-0.2.0] startup
[5.794s] [ext: omni.kit.window.status_bar-0.1.1] startup
[5.798s] [ext:] startup
[5.799s] [ext:] startup
[5.801s] [ext: omni.kit.manipulator.viewport-1.0.6] startup
[5.803s] [ext: omni.isaac.urdf-0.4.0] startup
[5.830s] [ext: omni.isaac.dofbot-0.3.0] startup
[5.831s] [ext: omni.kit.window.title-1.1.2] startup
[5.833s] [ext: omni.kit.profiler.window-1.4.4] startup
[5.838s] [ext: omni.graph.visualization.nodes-1.1.1] startup
[5.842s] [ext: omni.isaac.synthetic_utils-0.3.5] startup
[5.845s] [ext: semantics.schema.editor-0.2.3] startup
[5.848s] [ext: omni.isaac.sim.python-2022.1.1] startup
[5.849s] Simulation App Starting
[6.546s] app ready
[8.565s] Simulation App Startup Complete
2022-12-12 01:32:26 [8,553ms] [Warning] [omni.client.plugin]  Tick: authentication: Discovery(ws://localhost/omni/discovery): Error creating Auth/Credentials search: Not connected
2022-12-12 01:32:26 [8,553ms] [Warning] [omni.client.plugin]  Tick: authentication: Discovery(ws://localhost/omni/discovery): Error creating Auth/Tokens search: Not connected
2022-12-12 01:32:26 [8,553ms] [Warning] [omni.client.plugin]  Tick: authentication: Discovery(ws://localhost/omni/discovery): Error creating Api/Connection search: Not connected
/home/aic/.local/share/ov/pkg/isaac_sim-2022.1.1/./ line 40:  6203 Killed                  $python_exe "$@" $args
There was an error running python

Are you running Isaac Sim on a headless remote machine or on your desktop with monitor?
Most like it is trying to open a browser to authentication the Nucleus connection.
A workaround is to set the OMNI_USER and OMNI_PASS env var with your credentials. See 6. Setup FAQ — Omniverse Robotics documentation

Another method is to access the assets from the Cloud by adding this flag: -


If the above does not help please send us a copy of your python file for us to reproduce the issue locally.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.