Cannot create local Nucleus Service

Hi , One day I switched on my PC and Omniverse launcher is started. but showed “The Nucleus service appears to be unresponsive.” message and will never start it any more.
I need your help to resolve this issue.



Ubuntu 20.04
RTX3090(Driver Version: 515.43.04]

1.clear cache and reinstall it. ---> no change
  1. clear the all data by cleanup tool
    sudo ./launcher-cleanup
    —> no change

3.uninstall and create new Local Nucleus service
–>no change

12:10:32.638 › Retrying to register an account in 5s, error: Error: Failed to connect to the discovery service localhost
at up._connect (/tmp/.mount_omniveGwIVTw/resources/app.asar/dist/main.js:345:398879)
at runMicrotasks ()
at processTicksAndRejections (node:internal/process/task_queues:96:5)
at async up.find (/tmp/.mount_omniveGwIVTw/resources/app.asar/dist/main.js:345:397987)
at async Ze.retries (/tmp/.mount_omniveGwIVTw/resources/app.asar/dist/main.js:345:412456)
at async Ze (/tmp/.mount_omniveGwIVTw/resources/app.asar/dist/main.js:345:260027)
at async onInstallerProgress (/tmp/.mount_omniveGwIVTw/resources/app.asar/dist/main.js:345:409750)
12:10:37.647 › Failed to connect to the discovery service using port-based routing (ws://localhost:3333): {
target: {
_events: {
message: ‘[function] function a(e){t.call(this,new n(e,this))}’,
open: ‘[function] function l(){t.call(this,new s(this))}’,
error: ‘[function] function c(e){t.call(this,new o(e,this))}’,
close: ‘[function] function p(e,i){t.call(this,new r(e,i,this))}’
},
_eventsCount: 4,
_binaryType: ‘arraybuffer’,
_closeCode: 1006,
_closeFrameReceived: false,
_closeFrameSent: false,
_closeMessage: ‘’,
_closeTimer: null,
_extensions: {},
_protocol: ‘’,
_readyState: 3,
_receiver: null,
_sender: null,
_socket: null,
_bufferedAmount: 0,
_isServer: false,
_redirects: 0,
_url: ‘ws://localhost:3333’,
_req: null

  1. check the config file in the /nucleus-workstation-2022.1.2/ folder
    I found the below config file.but my system is not windows.
    it looks windows setting…

~/.local/share/ov/pkg/nucleus-workstation-2022.1.2/setup/configs/Nucleus$ cat Omniverse.toml
[main]
instdir = “C:\Program Files\NVIDIA Corporation\Omniverse\Nucleus”
parent_product_name = “Omniverse”
product_name = “Nucleus”
version = “113.19”
shortcut_name = “”
exe_name = “omni.server.app”
exe_cmdline = “”
multi_user = “Admin”
auto_launch = true
use_launcher = true
visible_to_users = true
use_task_scheduler = false
save_manifest = false

<http://localhost:3080/ information>
Cannot connect to System Monitor Backend.

Hello @mikaneda. I’ve asked the dev team to take a look. I’ll post back when I have more information.

Hello Wendy. Thank you for your response.
If I need to provide more information such a log file or setting, please let me know.

hey Mikaneda,

I had same error, and while it sounds elementary, did you restart your comp? worked for me after a full system restart.

Hi michael,

I couldn’t resolve this failure to restart PC.
After occurred this symptom, I cannot create local nucleus any more.

Hi , I can resolved to removed all folder below.

~/.local/share/ov
~/.cache/ov
~/.nvidia-omniverse
~/.config/omniverse
~/.config/omniverse-launcher

after execute omniverse-launcher-linux.AppImage, start reinstall.

Thank you!

@mikaneda Thank you for the update and I’m glad that you were able to get your system back up and running. If you run into any additional issues, please feel free to reach out to us for help!

Thanks!
Drew

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.