USDComposer cannot "see" files on enterprise nucleus


we have an omniverse connector that connects to an enterprise nucleus and updloads files. We can see and download those files with Omniverse Launcher, Nucleus Navigator and the web interface from nucleus server.

But, when connecting with Create / USD-Composer, we cannot see the files that where uploaded from our connector. Create and the connector use both the same user and the uploaded file are owned by that user.

Any idea what could cause this behavior?



Could you delete and recreate the link to your server inside of Composer AFTER you have established a good link to the server inside of Nucleus. Sometimes the links can go stale.

Of course we already tried that… same result… connects fine… I can see everything except the files that are uploaded by our connector.

Files that are create by our connector (not uploaded) are visible

Could you send some screenshots showing the issue or better you a detailed video walkthrough of the problem. I am not sure what you mean by “uploading via the connector”. The connector doesn’t upload anything. It can export a usd file and textures into either a local host nucleus or a server nucleus, or it can send files into a live session, directly into composer. What connector for what software ? Are you running the latest version of everything ? Can you give me more details on your workflow.

Can you test your local host system first to see if that is working as expected locally without your ov server. Can you give me details of where you are uploading ? Is it an internal company nucleus or external or cloud hosted ?

Hi Richard,

thank you for coming back to this. Here is a small but more detailed explanation of our workflow…

Our main product a product configuration system for furniture and we have written our own connector for this, that’s what I mean when talking about “the connector”. This connector talks to the the nucleus through the c+±api and creates a new stage on the nuclues for every configuration session that is created in our system and synchronizes the scene graph of the configured furniture to the USD stage. The stage is created by calling UsdStage::New.

When an Asset is missing on the Nucleus, our connector uploads that missing assets by calling…
…omniClientCopy with a local filename and an nucleus uri
…omniClientWriteFile with a nuclus uri and the file content

This all works fine when using a workstation nuclues under windows (I haven’t tested it with a workstation nucleus under linux).

But when connecting to our enterprise nucleus we have the strange problem that the uploaded files are not visible to usd-composer. Only nucleus navigator can “see” them. But we know that the files are uploaded because we can download them with navigator.

And this is definitely not a problem on my maschine, because we have tested it with different machines and the result is the same… usd compose cannot see the files, that are uploaded from our connector.

We are using the latest version of USD composer and nucleus client api. But our enterprise nucleus is not the latest version, but one of the latest (sorry, I do not have the exact version number at the moment).

I hope that helps


Thanks for the details. The problem is that if you wrote your OWN connector from scratch, I have no way to validate, test, or advise you on that. I am not sure where I would be able to direct you for help. I acknowledge that it works one way, and not the other, but again, its a custom connector. There could literally be 100s of possible reasons for this. Since you are on Enterprise, have you reached out to your Enterprise rep for direct support ?

I will see who I can find to help. This is obviously very advanced support.

We habe not yet bought Enterprise because we habe this strange issue… but we are currently in the process of buying Enterprise, so I hope we will habe access again soon.

But what I’ve found out so far:
Our connector does create a stage in memory and then exports that stage to the nucleus… result: USD-Compose cannot see that file.

The we habe changed that to using omniClientCopy… saving the stage locally and then upload the file to new nucleus… same result.

So at the end, the minimal problem description is as follows:
Just use omniClientCopy to copy a local file to the nucleus… that’s it! Every application now see the file… except USD-Compose… I habe absolutely no idea what else I could do…


it has nothing to do with “our own connector”. Even when uploading files with Nucleus Navigator some of those files are invisible to Create / USD Compose.

It has to bee something in the configuration of our Nucleus…

Thanks for your help

just curious - is this on an admin account or a user? just trying to rule out ACL related possibility.

Yes it sounds like you should a) make sure everything is up to date. All drivers, all software. Especially Nucleus and Navigator. b) re-install Navigator if you have to c) Confirm that it is just composer and not other apps like Presenter etc.