Using RTXDI with nanite

Hello
I’m using NvRTX UE5.3.1 on my RTX 3070 TI and I have a question about RTXDI. As far as I understand, RTXDI works with Raytraced Shadows and there is a problem with shading due to the working principle of Nanite technology. I wonder if it is possible to solve this
problem in such a way that both nanite and RTXDI stay open?


Thank you,

Hi @Ozan_Gunduz, what kind of issue do you see? Is it a red/pinkish overlay (judging from the image)? That might actually some development overlay. Might be worth checking.

In any case, I am not aware that nanite and RTXDI would clash. In fact I recommend checking out this Webinar from last month where our RTXDI evangelist goes into some detail on how to create fabulous shadow effects in UE.

I’m talking about distorted shadows popping up everywhere. In the official version of Unreal Engine, this situation also occurs when you turn on ray-traced shadows, but it can be corrected with some commands. But in the NvRTX version, these solutions do not work. We want to be able to use Nanite and RTXDI together, but we encounter this problem. William Faucher posted a video on his youtube channel about what caused this problem and offered a few solutions, but these solutions do not work with RTXDI. Do you have any ideas on how we can use these two technologies together? maybe they can help if you can forward it to the NvRTX/RTXDI developer team

Here is the link to the video i’m talking about: https://youtu.be/F3XSKXhIAuU?si=_mmYUgFmT2pP0jNl

Got it, thanks.

I reached out internally, let’s see if we can get some feedback.

I received feedback and some advice on how to make it work:

The answer is yes, RTXDI and Nanite work together.
There are 2 cvars to mess with.
r.RayTracing.Nanite.Mode default 0, set it to 1 and possibly r.RayTracing.Shadows.AvoidSelfIntersectionTraceDistance. Giving it a value greater than 0, like 10 for example and adjust from there.
Setting the first cvar may be all that’s needed. The 2nd cvar can be useful for large meshes or even landscape, and doing further adjustments. Both of these come at a small performance cost, so they should only be used as necessary. If they only need 1 cvar to do the job, then stop with that.
These fixes work by using local screen traces as a workaround since the full resolution mesh isn’t included in nanite to do proper ray tracing from. It should make nanite meshes under ray tracing look correct and with less artifacts, even if its not 100% technically correct.

I hope that helps!

it worked for me, Thanks a lot!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.