Verifying that new preview driver is v465.12

Hi,

I just want to make sure that the new preview driver announced here is version 465.12. When I run the installer, GeForce Experience opens automatically, but it says that 465.12 has been around since 8/17/20 - the announcement is dated 11/16/20. Seems like something’s off there…

I’m in both the NVidia Developer program and the Microsoft Windows Insider Program, so I should be able to access the new driver rather than being directed to the previous one.

The announcement doesn’t specifically say that the driver is only for the RTX-30 series, it just singles out some features for that series. I have an RTX2080 Ti - wondering if maybe that’s the deal? Or maybe that IS the new driver and GeForce Experience is displaying the wrong date?

Any info would be welcome. Thanks…

Yes indeed. The WSL driver is based off 465.12. The 465.12 is the absolute bleeding edge.
Could you point us to where you found the date 8/17/20?

You’ll be able to get the driver versions more accurately in the WSL in the changelog

For instance, for the 11/16 update, you will be able to find the driver version as listed below.

11/16/2020: The following software versions are supported with this preview release for WSL 2:

  • NVIDIA Driver for Windows 10: 465.12

I am having issues with 465.12 for Quadro.

Upon starting up my device, I can see an issue with my GPU driver in device manager:
image

And CUDA throws error 35:
image

I can workaround by disabling, then enabling the driver in device manager. After doing this, everything works fine (until I restart my device and have to disable/enable manually again).

I am on Windows 20262.1 (20262.fe_release.201113-1436)

I am also having issues with 465.12 - CUDA has stopped working on WSL2 WIndows Insider build 20262.fe_release.201113-1436

I suspect MS has gone backwards with this build and removed features like GPU virtualization. Hopefully it will come back soon.

Toggling device driver did not help me.

Switched to GameReady driver (I have RTX 5000 and I was using Quadro before) - but still no luck.

Yes. As I said in the original post: “When I run the installer, GeForce Experience opens automatically, but it says that 465.12 has been around since 8/17/20.”

@asundaram: Here’s a screenshot of GeForce Experience displaying the wrong date:

When I clicked on the driver to install it, GeForce Experience updated itself before proceeding. Control Panel -> Programs and Features says GeForce Experience version is 3.20.5.70.

@asundaram - Also, just want to verify that nvidia-smi is still not supported in this version of the driver.

It’s failing in code that I’m trying to run, but I’m pretty sure that’s still the expected outcome at this point. If you can verify, that would be cool.

Even cooler (but you probably can’t) - if you can shed light on approximately when we might begin to have some semblance of a whisper of a dream of a rumor of a hope that it might be supported, that would be great!

Hi hypertree,

We have posted an update on a specific installation issue reported earlier when using the latest WIP driver 465.12 on mobile platforms. Please check our latest announcement.

At this point, the problem you are reporting seems to be a different one than what’s already being reported. Our latest WIP update (20262) does have GPU virtualization in WSLv2 enabled and that has been tested. So that may not be the issue.

Could you follow the general troubleshooting guide in the user guide and provide us with below information.

On the device manager do you see the GPU enabled ?

Could you share us with the Dxdiag output ?

Are you able to see folders like /dev/dxg and /lib/wsl/lib ?

Could you share the content of /lib/wsl/lib ?

Thank you for the screenshot. We will look into it.

I see CUDA acceleration in Windows and GPU is active - I have toggled it inactive and then active - no difference to WSL.

/dev/dxg is empty

/lib/wsl/lib looks like this:

libcuda.so ‘libd3d12 (2).so’ libd3d12core.so ‘libdxcore (1).so’ libnvwgf2umx.so
libcuda.so.1 libd3d12.so ‘libdirectml (1).so’ ‘libdxcore (2).so’
libcuda.so.1.1 ‘libd3d12core (1).so’ ‘libdirectml (2).so’ libdxcore.so
‘libd3d12 (1).so’ ‘libd3d12core (2).so’ libdirectml.so libnvidia-ml.so.1

Could you please attach dxdiag output? Are you seeing this issue in Desktop?

Could you explain what you mean by the below:
"I see CUDA acceleration in Windows and GPU is active "