Vino-server autostarting but then stopping automatically on Orin Nano

I am in the process of getting vino-server running on my Orin Nano that I previously was running on my Xavier NX without issue. On my Xavier NX, I was able to follow these instructions and everything works well.

On the Orin Nano, I followed the same instructions, but it seems that vino-server is autostarting, but then autostopping. I can start it up again manually and everything works, but I am wondering why it is stopping right after it autostarts.

When I run systemctl --user status vino-server.service it shows this:

     Loaded: loaded (/usr/lib/systemd/user/vino-server.service; static; vendor preset: enabled)
     Active: inactive (dead) since Fri 2023-08-11 09:49:30 MDT; 41min ago
    Process: 3438 ExecStart=/usr/lib/vino/vino-server (code=killed, signal=TERM)
   Main PID: 3438 (code=killed, signal=TERM)

Aug 11 09:49:03 ubuntu vino-server[3438]: 11/08/2023 09:49:03 AM Advertising security type: 'TLS' (18)
Aug 11 09:49:03 ubuntu vino-server[3438]: 11/08/2023 09:49:03 AM Advertising authentication type: 'VNC Authentication' (2)
Aug 11 09:49:03 ubuntu vino-server[3438]: 11/08/2023 09:49:03 AM Clearing securityTypes
Aug 11 09:49:03 ubuntu vino-server[3438]: 11/08/2023 09:49:03 AM Clearing authTypes
Aug 11 09:49:03 ubuntu vino-server[3438]: 11/08/2023 09:49:03 AM Advertising security type: 'TLS' (18)
Aug 11 09:49:03 ubuntu vino-server[3438]: 11/08/2023 09:49:03 AM Advertising authentication type: 'VNC Authentication' (2)
Aug 11 09:49:03 ubuntu vino-server[3438]: 11/08/2023 09:49:03 AM Advertising security type: 'VNC Authentication' (2)
Aug 11 09:49:30 ubuntu systemd[1375]: Stopping Vino VNC server...
Aug 11 09:49:30 ubuntu systemd[1375]: vino-server.service: Succeeded.
Aug 11 09:49:30 ubuntu systemd[1375]: Stopped Vino VNC server.

I’m running Jetpack 5.1.1 (Ubuntu 20.04)

As far as I can recall, I have done everything exactly the same as when I set this up on my Xavier NX (Jetpack 4.6.2 - Ubuntu 18.04).

The vino-server.service file looks like this:

[Unit]
Description=Vino VNC server

[Service]
Type=dbus
BusName=org.gnome.Vino
ExecStart=/usr/lib/vino/vino-server
Restart=on-abnormal

Any idea what’s going on here, how to fix it, or how I can get to the bottom of what is happening?

Edit (a bit more info): It seems to run fine if I just manually do systemctl --user restart vino-server.service

So it’s only when my system is first starting up that its a problem. I tried adding some delay with ExecStartPre=/bin/sleep 10 (and 20, 30, 60), but that seemed to cause another error:

-- Logs begin at Thu 2022-09-08 03:58:15 MDT. --
Aug 11 11:48:47 ubuntu systemd[1380]: Starting Vino VNC server...
Aug 11 11:48:50 ubuntu systemd[1380]: vino-server.service: Control process exited, code=killed, status=15/TERM
Aug 11 11:48:50 ubuntu systemd[1380]: vino-server.service: Failed with result 'signal'.
Aug 11 11:48:50 ubuntu systemd[1380]: Stopped Vino VNC server.

which suggests to me it isn’t even able to do the ExecStartPre=/bin/sleep 10, but I’m no expert.

Hi petervonhahn,

Are you using the devkit or custom board for Orin Nano?

Could you help to verify with the latest JP5.1.2(R35.4.1)?

I am using the devkit. I would rather not update to Jetpack 5.1.2 right now, as I have put a bunch of stuff on it already and I don’t really want to have to reinstall everything. I have found a workaround to get my VNC server running for now, but I am still curious why the instructions on your site did not work for the Orin Nano.

That instruction seems published few years ago.

Could you help to kindly share the workaround in your case?
Maybe we need to update that tutorial.

Sure. I just removed the systemd service link in /usr/lib/systemd/user/graphical-session.target.wants and then added /usr/lib/vino/vino-server to the Ubuntu Startup Applications. I still did all the gsettings configuration stuff for vino.

It seems the default state of Screen Sharing in Orin Nano is Off.

You could enable it through Settings->Sharing->Screen Sharing->Enable through the toggle.

and you would run systemctl --user status vino-server.service and see it’s active(running).

Yeah, perhaps this is the crux of it: I am running my Jetson Orin Nano as a wifi hotspot, which prevents me from enabling screen sharing the way you describe (why?). This was true with my Xavier NX too, but the vino-server.service would still start up. Anyway, just autostarting vino-server without using a systemd service seems to work.

If you are using hotspot, it seems vino-server would not run automatically.
Please try to run the following command on your board.

$ DISPLAY=:0 /usr/lib/vino/vino-server &

That’s not really the issue though. I can run /usr/lib/vino/vino-server just fine once the system is booted up. It’s just at startup time that the systemd service doesn’t work for some reason. Just pointing that out for the benefit of others who may encounter this issue. I have moved on, personally, but I am still curious why it didn’t work.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.